Basic POP email setup guide

Discussion in 'Installation/Configuration' started by xavier, Nov 24, 2006.

Thread Status:
Not open for further replies.
  1. xavier

    xavier New Member

    Hi, this is the second ISPCONFIG box I have setup up, but the first time I am configuring it to handle email.

    Fresh Mandriva 2006 following the "Perfect Guide." Not using DNS, the DNS is through my ISP. In ISPCONFIG, I created new site, with a user "web4_admin" whose email I would like to be "[email protected]"

    When I check "/etc/postfix/virtusertable" I see one of the lines seems to be setup to receive mail there:
    Code:
    [email protected]    web4_admin
    [email protected]    web4_admin
    [email protected]    web4_admin
    [email protected]    web4_admin
    
    But when I send an email to that, I get the reply

    Code:
    Hi. This is the qmail-send program at st08.startlogic.com.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.
    
    <[email protected]>:
    208.201.249.230 does not like recipient.
    Remote host said: 550 5.1.1 <[email protected]>... No such user here
    Giving up on 208.201.249.230.
    
    also tried emailing the username directly: still no dice

    Code:
    208.201.249.230 does not like recipient.
    Remote host said: 550 5.1.1 <[email protected]>... No such user here
    Giving up on 208.201.249.230.
    

    I read the post at http://www.howtoforge.com/forums/showthread.php?t=2

    But that seemed command-line oriented; I did everything through the control panel. I must have missed something, where can I read more about basic POP email setup with ISPCONFIG ... or what are the next logical troubleshooting steps?

    Thanks in advance,

    xavier
     
    Last edited: Nov 25, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your main.cf file contains these two lines:

     
  3. xavier

    xavier New Member

    Yes, it contains those lines verbatim, full contents below I did notice in "main.cf" a couple parameters that seemed weird:

    Code:
    mydomain = example.com
    myhostname = server1.$mydomain
    
    Could that be the problem? Below find the complete contents of main.cf:

    Code:
    # These are only the parameters changed from a default install
    # see /etc/postfix/main.cf.dist for a commented, fuller version of this file.
    
    # These are changed by postfix install script
    readme_directory = /usr/share/doc/postfix-2.2.5/README_FILES
    html_directory = /usr/share/doc/postfix-2.2.5/html
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    command_directory = /usr/sbin
    manpage_directory = /usr/share/man
    daemon_directory = /usr/lib/postfix
    newaliases_path = /usr/bin/newaliases
    mailq_path = /usr/bin/mailq
    queue_directory = /var/spool/postfix
    mail_owner = postfix
    
    
    
    # User configurable parameters
    inet_interfaces = all
    mynetworks_style = host
    delay_warning_time = 4h
    smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandriva Linux)
    unknown_local_recipient_reject_code = 450
    smtp-filter_destination_concurrency_limit = 2
    lmtp-filter_destination_concurrency_limit = 2
    smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
    recipient_delimiter = +
    owner_request_special = no
    alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mydomain = example.com
    myhostname = server1.$mydomain
    mydestination = /etc/postfix/local-host-names
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    home_mailbox = Maildir/
    mailbox_command =
    
     
    Last edited: Nov 25, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    Are the MX records of your domains correct? Do they point to the correct server?
     
  5. xavier

    xavier New Member

    Yes, when I check it out at dnsstuff.com, I see this

    Code:
    mysitenet.	MX	IN	7200	mail.mysite.net. [Preference = 10]
    mysite.net.	MX	IN	7200	custmx.sonic.net. [Preference = 20]
    
    I also tried changing the following lines in /etc/postfix/main.cf to this ...

    Code:
    mydomain = mysite.net
    myhostname = mail.$mydomain
    
    But that didn't work, so I changed them back to the original ...

    Code:
    mydomain = example.com
    myhostname = server1.$mydomain
    
    Below find the tail of /var/log/mail/info. You can see the connection attempt starting at 19:59. There is an error for name service server1.example.com, not sure what to do next.

    Code:
    Nov 27 19:52:11 colo ipop3d[26293]: pop3 service init from 66.65.62.41
    Nov 27 19:52:12 colo ipop3d[26293]: Login user=web4_admin host=cpe-66-65-62-41.nyc.res.rr.com [66.65.62.41] nmsgs=0/0
    Nov 27 19:52:12 colo ipop3d[26293]: Logout user=web4_admin host=cpe-66-65-62-41.nyc.res.rr.com [66.65.62.41] nmsgs=0 ndele=0
    Nov 27 19:53:33 colo postfix/anvil[26222]: statistics: max connection rate 1/60s for (smtp:66.235.193.134) at Nov 27 19:48:10
    Nov 27 19:53:33 colo postfix/anvil[26222]: statistics: max connection count 1 for (smtp:66.235.193.134) at Nov 27 19:48:10
    Nov 27 19:53:33 colo postfix/anvil[26222]: statistics: max cache size 1 at Nov 27 19:48:10
    Nov 27 19:59:34 colo postfix/smtpd[26388]: connect from st08.startlogic.com[66.235.193.134]
    Nov 27 19:59:34 colo postfix/smtpd[26388]: 57A4B8AC267: client=st08.startlogic.com[66.235.193.134]
    Nov 27 19:59:34 colo postfix/cleanup[26392]: 57A4B8AC267: message-id=<[email protected]>
    Nov 27 19:59:34 colo postfix/qmgr[6699]: 57A4B8AC267: from=<[email protected]>, size=1052, nrcpt=1 (queue active)
    Nov 27 19:59:34 colo postfix/smtpd[26388]: disconnect from st08.startlogic.com[66.235.193.134]
    Nov 27 19:59:34 colo postfix/smtp[26394]: 57A4B8AC267: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=A: Host not found)
    Nov 27 19:59:34 colo postfix/cleanup[26392]: 7D8648AC26A: message-id=<[email protected]>
    Nov 27 19:59:34 colo postfix/qmgr[6699]: 7D8648AC26A: from=<>, size=3009, nrcpt=1 (queue active)
    Nov 27 19:59:34 colo postfix/qmgr[6699]: 57A4B8AC267: removed
    Nov 27 19:59:34 colo postfix/local[26397]: 7D8648AC26A: to=<[email protected]>, relay=local, delay=0, status=bounced (unknown user: "xavier")
    Nov 27 19:59:34 colo postfix/qmgr[6699]: 7D8648AC26A: removed
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please change it back to
    Code:
    mydomain = mysite.net
    myhostname = mail.$mydomain
    and restart Postfix. Then this error:
    shouldn't occur anymore.

    Is [email protected] listed in /etc/postfix/virtusertable?
     
  7. xavier

    xavier New Member

    We fixed this offline, but I just wanted to respond in this thread, close the issue. The problem was with the settings in main.cf, changing it to

    mydomain = mysite.net
    myhostname = mail.$mydomain

    worked like a charm.

    x
     
Thread Status:
Not open for further replies.

Share This Page