Backups do not work

Discussion in 'Installation/Configuration' started by kike28101, Nov 23, 2016.

  1. kike28101

    kike28101 New Member

    Hello everyone

    I need help for ISPConfig 3
    Since I upgraded to the new version Current version: 3.1.1p1, I do not back up the two web pages I have on the panel,
    In the buckup tab of Domain Web, are activated Interval of backup in daily and in Number of backups are in 2

    In System> Server, the time for buckups is activated, the checkbox in the Backup directory is also checked?
    I've missed something?

    It's a VPS with Debian 8 Jessie

    I do not know what it can be, in the old version it worked very well the backups
    Thank you
    enric
     
  2. Jesse Norell

    Jesse Norell Active Member

    Do you have the /usr/local/ispconfig/server/plugins-enabled/backup_plugin.inc.php symlink created? If so, try turning on debug mode and see if you can find what's going on when server.sh runs.
     
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    The plugin is not used to create backups. You need /usr/local/ispconfig/server/lib/classes/cron.d/500-backup.inc.php for web / db-backups. Check that you defined a backup-dir in the server-config and make sure, that the folder exists.
    To debug backups: php /usr/local/ispconfig/server/cron_debug.php --cronjob=500-backup.inc.php
     
  4. kike28101

    kike28101 New Member

    Reply to Jesse Norell
    Yes, I have the symbolic link created /usr/local/ispconfig/server/plugins-enabled/backup_plugin.inc.php

    I put the server in debug mode
    I have run it by console - crontab -e
    And then I have executed /usr/local/ispconfig/server/server.sh

    This is the result:

    23.11.2016-22: 34 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    23.11.2016-22: 34 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    Finished.

    Is this what you asked me to do ??
    I'm lost .... what should I do?
    Thank you
     
  5. kike28101

    kike28101 New Member

    Reply to Florian030
    This tells me /usr/local/ispconfig/server/lib/classes/cron.d/500-backup.inc.php for web / db-backups.
    I have it, it's in the folder

    In the server configuration is defined the directory for backups in /var/buckup, and the folder is created with 750 permissions, this is how it was created in the installation

    What else can I check to find a solution?
    Thanks
    Enric
     
  6. Jesse Norell

    Jesse Norell Active Member

    Sorry, irrelevant to this issue.

    See @florian030's reply for debugging that specific cron job
     
  7. kike28101

    kike28101 New Member

    I have installed everything new from scratch Debian 8 Jessie new clean and (InstallThe Perfect Server - Debian 8.4 Jessie (Apache2, BIND, Dovecot, ISPConfig 3.1) cleans)

    Configuration of the standard server without modifying anything

    Only create client, database, dns, domain, upload a copy of a website plus the database and wait if ISPConfig makes the backups of 1 per day and at the scheduled time

    Does not work .... does not backup

    Someone knows that it could be this bug that does not create buckups the new version of ISPConfig

    Thanks
     
  8. kike28101

    kike28101 New Member

    Hi Florian
    Sorry my English (Spanish)
    I already saw your post and answered
    What do I have to change?
    • The plugin is not used to create backups.
    I do not understand ....
    I have not installed any plugin, I repeat that it is a direct clean installation of ISPConfig I have not changed anything and I have not added anything
    • You need /usr/local/ispconfig/server/lib/classes/cron.d/500-backup.inc.php
    This I have in this route that you indicate to me, ....
    I have to copy it to another place?
    I have to change it?
    What should I do with it?
    Do you want me to access my panel and see it yourself?
    With the version prior to this panel update, the backups worked perfectly for more than 10 months that had it installed

    Do you think there is a solution?
    Thanks
     
  9. kike28101

    kike28101 New Member

    There is no one in ISPConfig who can know why the new version does not perform the buckups of the websites
     
  10. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    From #3:
    To debug backups:
    Code:
    php /usr/local/ispconfig/server/cron_debug.php --cronjob=500-backup.inc.php
     

Share This Page