Backuppc user permissions, 12,776 permission denied errors!

Discussion in 'Server Operation' started by DrJohn, Dec 15, 2007.

  1. DrJohn

    DrJohn Member HowtoForge Supporter

    <Gutsy 7.10, backuppc 3.0.0 installed per Back Up Linux And Windows Systems With BackupPC tutorial>

    Install was flawless, but I didn't set up the remote clients (yet). First I want to use Backuppc to backup the server's unique files and archive them to a removable device (REV 35 GB drive). After that's running smoothly I'll migrate the client backups from the current windows situation and move the 750GB removable drive over to the server for this purpose. First, though, to get it running at all...

    I set localhosts xfer method to tar (override), tarsharename (0verride) to '/', and excluded '/proc' and '/tmp' as overrides.

    Leaving the default schedule in place, I got a large number of permission denied faults. Many were in /sys (perhaps I should exclude it too?), but also in areas I need to backup such as /home, /var/log, /usr/share, and so-on.

    It seems like the backuppc user doesn't have sufficient permission to access/read the files / directories. I've not tried to join the backuppc user to another group (it's in it's own default 'backuppc' group now).

    To save me the grief of poking around until I stumble on the answer, which group would be appropriate, and exactly which command (s) will make the change?


    Dr. John
  2. DrJohn

    DrJohn Member HowtoForge Supporter

    Fixed it

    I changed TarClientCmd command to use sudo and gave the backuppc user the necessary permission so that tar runs as root. This has eliminated the problem with permission denied. But it still wasn't working as it should until I found a cockpit error in the excluded file specs.

    Now it works very well. I have one question, though, which is why do I still see a couple of attempts to back up the excluded directory /var/log/backuppc? There are five or six of these in the log:
    /bin/tar: ./var/lib/backuppc/pc/localhost/new/f%2f/fvar/flib/fbackuppc/fpc/flocalhost/fnew/ff%252f/ffvar/fflib/ffbackuppc/ffpc/fflocalhost/ffnew/fff%25252f/fffvar/ffflib/fffbackuppc/fffpc/ffflocalhost/fff0/ffff%2525252f/ffffvar: file changed as we read it
    I had thought that excluding the backuppc destination would prevent this kind of recursion from happening. What can I do to fix this? Here's /etc/backuppc/

    # Local server backup of /etc as user backuppc
    $Conf{XferMethod} = 'tar';
    $Conf{TarShareName} = [
    $Conf{TarClientCmd} = '/usr/bin/sudo /usr/bin/env LC_ALL=C $tarPath -c -v -f - -C $shareName --totals';
    # remove extra shell escapes ($fileList+ etc.) that are
    # needed for remote backups but may break local ones
    $Conf{TarFullArgs} = '$fileList';
    $Conf{TarIncrArgs} = '--newer=$incrDate $fileList';
    $Conf{BackupFilesExclude} = {
      '*' => [


  3. DrJohn

    DrJohn Member HowtoForge Supporter

    Correction: '/var/lib/backuppc'


Share This Page