Backuppc Error on Install...

Discussion in 'HOWTO-Related Questions' started by matthewjamesnewton, Oct 29, 2007.

  1. matthewjamesnewton

    matthewjamesnewton New Member

    Hi,

    I'm trying to follow along with: http://www.howtoforge.com/linux_backuppc

    And after I try to run (as root): apt-get install backuppc rsync libfile-rsyncp-perl smbfs

    I get....

    Setting up backuppc (2.1.2-2ubuntu5) ...
    * Starting backuppc... 2007-10-29 09:29:35 $Conf{SendmailPath} = '/usr/sbin/sendmail' is not a valid executable program
    invoke-rc.d: initscript backuppc, action "start" failed.
    dpkg: error processing backuppc (--configure):
    subprocess post-installation script returned error exit status 1
    Setting up smbfs (3.0.22-1ubuntu3.3) ...
    Errors were encountered while processing:
    backuppc
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    It looks like its some what working because I'm able to login but once In I see the menu options but at the top of the page it says...

    "Unable to connect to server."
    Any ideas?
     
  2. falko

    falko Super Moderator

    What's the output of
    Code:
    which sendmail
    and
    Code:
    ls -l /usr/sbin/sendmail
    ?
     
  3. matthewjamesnewton

    matthewjamesnewton New Member

    Sorry for my delay, that hard drive actually died so I'm doing this on an other install. I follow the instructions and I get through them with out any errors until I run a...

    dpkg-reconfigure backuppc

    It returns this...

    root@callisto:/mnt# dpkg-reconfigure backuppc
    * Stopping backuppc... No process in pidfile `/var/run/backuppc/BackupPC.pid' found running; none killed.
    [ ok ]
    /var/lib/dpkg/info/backuppc.postinst: line 45: /usr/share/wwwconfig-common/apache-include_all.sh: No such file or directory
    root@callisto:/mnt#

    I'm able to pull up the Web interface which still says "Error: Unable to connect to BackupPC server."

    The logs on the website only say... "Contents of file /var/lib/backuppc/log/LOG, modified 2007-10-31 10:51:55

    2007-10-31 10:44:03 Reading hosts file
    2007-10-31 10:44:03 Added host localhost to backup list
    2007-10-31 10:44:03 BackupPC started, pid 29374
    2007-10-31 10:44:03 Running BackupPC_trashClean (pid=29375)
    2007-10-31 10:44:03 Next wakeup is 2007-10-31 11:00:00
    2007-10-31 10:51:55 Got signal TERM... cleaning up
    "

    Any Ideas?
     
  4. falko

    falko Super Moderator

    Can you try this?
    Code:
    apt-get update
    apt-get upgrade
     
  5. matthewjamesnewton

    matthewjamesnewton New Member

    I kept on going with the install and it just started to work...

    Thanks for your help.

    MN
     

Share This Page