Backup of files not working, while databases are backedup

Discussion in 'Installation/Configuration' started by lonerunner, Nov 25, 2013.

  1. lonerunner

    lonerunner New Member

    I have problem as title said.

    For almost a year everything worked fine. I have set backup of few websites that i have on my server and selected to keep 5 backups of each, and every week new backup is made, untill i recently loged in and noticed that there are no new backups.

    What's maybe strange it seems that problem started to happens since last ispconfig update.

    I don't see any errors in logs also.

    While checking ispconfig.log file i see only error http is down, but that's normal, server gets a bit overloaded sometime. But last log is 5.10.

    In cron.log this appeared now when i restarted server

    Mon Nov 25 19:45:15 UTC 2013 PHP Warning: mysqli::escape_string(): Couldn't fetch db in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 215
    Mon Nov 25 19:45:15 UTC 2013 PHP Warning: mysqli::close(): Couldn't fetch db in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 82

    Checking crontab file i have these in the file

    * * * * * /usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done
    30 00 * * * /usr/local/ispconfig/server/cron_daily.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done

    Checking ispconfig backup file last backup file of ispconfig was made 5.10. and im guessing this was made when ispconfig was updated to latest version.

    But in website backups i have 2 different backup files one is .zip from website files and other is .gz from databases.

    Database files are backedup regularly but website files are not backing up for some reason last backup was made before last ispconfig update.

    And i have enought space on HDD for a backup (it hase 60% free space). And i don't know where to look anymore to find why websites are not backing up.
     
  2. lonerunner

    lonerunner New Member

    Is it possible that no one else have this problem. Please help?
     
  3. gutek

    gutek New Member

    I have same problem. Any sugestions? "Fresh" installation 3.0.5.3 on Ubuntu 12.04.4 LTS.
     
  4. lonerunner

    lonerunner New Member

    I made some kind of workaround. In Websites i set every website to backup daily. And in System > Server config i set backup mode to "Backup all files in web directory as root user.
     

Share This Page