Backup not working on ispconfig 3.1.3 and 3.1.4

Discussion in 'Installation/Configuration' started by byman64, Jun 25, 2017.

  1. neutrinohu

    neutrinohu New Member

    Hi,

    I've everything installed

    [email protected]:/www/backup/web9# zip
    Copyright (c) 1990-2008 Info-ZIP - Type 'zip "-L"' for software license.
    Zip 3.0 (July 5th 2008). Usage:
    zip [-options] [-b path] [-t mmddyyyy] [-n suffixes] [zipfile list] [-xi list]
    The default action is to add or replace zipfile entries from list, which
    can include the special name - to compress standard input.
    If zipfile and list are omitted, zip compresses stdin to stdout.
    -f freshen: only changed files -u update: only changed or new files
    -d delete entries in zipfile -m move into zipfile (delete OS files)
    -r recurse into directories -j junk (don't record) directory names
    -0 store only -l convert LF to CR LF (-ll CR LF to LF)
    -1 compress faster -9 compress better
    -q quiet operation -v verbose operation/print version info
    -c add one-line comments -z add zipfile comment
    [email protected] read names from stdin -o make zipfile as old as latest entry
    -x exclude the following names -i include only the following names
    -F fix zipfile (-FF try harder) -D do not add directory entries
    -A adjust self-extracting exe -J junk zipfile prefix (unzipsfx)
    -T test zipfile integrity -X eXclude eXtra file attributes
    -y store symbolic links as the link instead of the referenced file
    -e encrypt -n don't compress these suffixes
    -h2 show more help

    [email protected]:/www/backup/web9# tar
    tar: You must specify one of the '-Acdtrux', '--delete' or '--test-label' options
    Try 'tar --help' or 'tar --usage' for more information.

    [email protected]:/www/backup/web9# sudo
    usage: sudo -h | -K | -k | -V
    usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
    usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user] [command]
    usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user] [VAR=value] [-i|-s] [<command>]
    usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p prompt] [-T timeout] [-u user] file ...
     
  2. neutrinohu

    neutrinohu New Member

    How can i enable logging in /var/log/ispconfig/ispconfig.log?
    Or is this not for that purpose? Where can i find error logs related to config errors like this backup problem...etc?
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  4. neutrinohu

    neutrinohu New Member

    I've solved it.

    Backup tmp directory must exists in the system....

    upload_2019-9-10_11-3-16.png
     
  5. c3n

    c3n Member

    ON Debian systems upgraded 8 > 9 ... or updated:
    In some cases problems with MYSQL backup on upgraded systems are caused by too high PHP version (7.3)... so first of all check:
    update-alternatives --config php
    Than do:
    mysql_upgrade -u root -p
    In some cases deleting old MYSQL backups helps... for now I got several VPS and only upgraded were affected still fighting with one VPS...

    There are also problems with backup policy. In my opinion there should be some sort of settings to:
    1) split backup i.e. WWW -> weekly (1 backup) MYSQL --> daily (3 backups). In most cases WWW is not changing as fast... MYSQL is more valuable.
    2) on mounted NFS/SSH there should be option not to CHOWN
    3) also in cluster mode / multiserver some sort of log (error/warining) to see if there is a problem with backup. Now You dont know if there is no backup for MYSQL unless You check manually.
    4) lots of messages with mounted NFS backup:
    Code:
    Backup directory /var/backup could not be unmounted.
    The command
    /usr/local/ispconfig/server/scripts/backup_dir_umount.sh
    failed.
    I tried to delay umount. But I got this message even on new dedicated servers with no load and with small backup... I got this message randomly from different servers...
    5) I noticed that regardless of the settings, mail backup is performed on the server at midnight. Now i got high overload... i would like to split jobs and have possibility to setup HOUR/SERVICE per server.

    MY settings are latest ISPCONFIG 3.1.3/4 and mostly Debian 9 (updated daily).
     
  6. neutrinohu

    neutrinohu New Member

    It would be great if i change something in GUI it should be done at the machine (or at least get a proper error msg).

    This case was hard, because ispconfig did not told me anything about why it has not createing backup.
     
    Last edited: Sep 11, 2019

Share This Page