Backup not working on ispconfig 3.1.3 and 3.1.4

Discussion in 'Installation/Configuration' started by byman64, Jun 25, 2017.

  1. byman64

    byman64 New Member

    I have 2 servers with ispconfig, I am trying to use the panel feature for backup. Easy to configure. I also read the manual but nothing to add, this feature is really easy to use.
    I checked the folder and time in the backup in server config, then I configured a daily backup for some sites.
    Nothing happen and I dont know what I can check to fix the problem.
    I read some logs but nothing helped me
    What I can check? Any idea?
    thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you have the linux zip and sudo packages installed.
     
  3. byman64

    byman64 New Member

    I installed ISP config on ubuntu 16.04 using the guide "the perfect server"
    Zip and sudo seem installed,

    What I can check? Logs? Which one?


    reply from ZIP AND SUDO command
    root@vps01:~# zip
    Copyright (c) 1990-2008 Info-ZIP - Type 'zip "-L"' for software license.
    Zip 3.0 (July 5th 2008). Usage:
    zip [-options] [-b path] [-t mmddyyyy] [-n suffixes] [zipfile list] [-xi list]
    The default action is to add or replace zipfile entries from list, which
    can include the special name - to compress standard input.
    If zipfile and list are omitted, zip compresses stdin to stdout.
    -f freshen: only changed files -u update: only changed or new files
    -d delete entries in zipfile -m move into zipfile (delete OS files)
    -r recurse into directories -j junk (don't record) directory names
    -0 store only -l convert LF to CR LF (-ll CR LF to LF)
    -1 compress faster -9 compress better
    -q quiet operation -v verbose operation/print version info
    -c add one-line comments -z add zipfile comment
    -@ read names from stdin -o make zipfile as old as latest entry
    -x exclude the following names -i include only the following names
    -F fix zipfile (-FF try harder) -D do not add directory entries
    -A adjust self-extracting exe -J junk zipfile prefix (unzipsfx)
    -T test zipfile integrity -X eXclude eXtra file attributes
    -y store symbolic links as the link instead of the referenced file
    -e encrypt -n don't compress these suffixes
    -h2 show more help

    root@vps01:~# sudo
    usage: sudo -h | -K | -k | -V
    usage: sudo -v [-AknS] [-g group] [-h host] [-p prompt] [-u user]
    usage: sudo -l [-AknS] [-g group] [-h host] [-p prompt] [-U user] [-u user]
    [command]
    usage: sudo [-AbEHknPS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
    prompt] [-u user] [VAR=value] [-i|-s] [<command>]
    usage: sudo -e [-AknS] [-r role] [-t type] [-C num] [-g group] [-h host] [-p
    prompt] [-u user] file ...
     
  4. byman64

    byman64 New Member

    Can I run manually the site backup?
    I would like is any error appear...I am reading the file 500-backup.inc.php I could add some line to debug it, but I dont know how run the backup from command line...
     
  5. byman64

    byman64 New Member

    update:
    I just tried to change the server config
    FROM
    Backup all files in web directory as root user
    TO
    Backup web files owned by web user as zip
    and now the backup seems works fine.
    So the mystery is why as root user backups do not working.
    I would like investigate with your help, if you agree. But I need the instructions to run backup from command line and see if any error appear.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig cron plugins like the backup function can be run manually like this:

    /usr/local/ispconfig/server/cron_debug.php --cronjob=500-backup.inc.php
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Sorry, wrong command. Please use:

    php /usr/local/ispconfig/server/cron_debug.php --cronjob=500-backup.inc.php
     
  8. byman64

    byman64 New Member

    I changed the backup type as " Backup all files in web directory as root user" and from CLI Root backup works like a charm.

    why they didnt run at scheduled time?
    I am going to change the date time to force a backup at 1.00 pm
    I will revert you soon
     
  9. byman64

    byman64 New Member

    Using the command line with the option "Backup all files in web directory as root use" backup works fine...as said I tried again to schedule backup at 1.00pm but nothing happen and I dont know what I can check.
    We need a log to know if script was executed, of if a filter skipped the domain.
    In the ispconfig panel I don't see any log for backup, just stats.
    A log with basic info would be always useful, something like:
    - Started backup at ...
    - selected n records
    - backup of domain..
    - Finish backup at
    I am not the best php developer but I am able to read and write php code, if you dont have other stuff to check I can try to add some lines into 500-backup.inc.php to write a log and try to debug the issue. Let me know.
     

Share This Page