Backup issues with ISPConfig 2.2.37

Discussion in 'General' started by dimas, Aug 25, 2010.

  1. dimas

    dimas Member

    I have come upon a strange behavior (at least it seems strange to me) of ISPConfig 2.2.37 regarding backups.

    I don't even know if it's a bug or a feature )

    Sometimes I need to upload a full site on the server as an archive (in one file), especially if such a site has thousands of small files - as you know, it takes ages to upload them by FTP.

    So what I usually do is upload an archive by FTP, login to server by SSH as root (I haven't yet set up SSH for clients), locate the relevant "web" folder, unzip the achive and later chown all files and directories to the current FTP's username. Then, all these files will look as if they have been uploaded by FTP.

    Well - apparently it's not so now, because if I try to make a backup of such a site (via admin panel), ONLY files that were actually uploaded by FTP are included in it. The files that were unzipped as root and later chown-ed are not included, as if they are not there - but they are there! The database part is OK.

    So - what can you say, is it a bug? I've never noticed such behavior in earlier versions of the panel.
     
  2. till

    till Super Moderator

    Thats no bug. The backup contains only files that are owned by the user and group of the website. Looks as if you did not chown the files correctly. Make sure that the files you chowned have the same user AND group then the files that were uploaded with FTP.
     
  3. dimas

    dimas Member

    Thank you, it worked as soon as I changed the group as well as the user.
     

Share This Page