AWStats with ISPConfig 3.0.5.3 not working

Discussion in 'Installation/Configuration' started by Caracal, Nov 20, 2013.

  1. Caracal

    Caracal New Member

    Hello all. First of all, I must say that I'm totally new to this, so please excuse the stupid questions I may have! :)

    I seem to have a problem with my installation of ISPConfig 3.0.5.3 and awstats. It's been 2 days from the install, but stats are not working at all.

    This is what I get when trying to access /stats/:
    Code:
    Error: LogFile parameter is not defined in config/domain file 
    
    Setup ('/usr/lib/cgi-bin/awstats.conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).
    
    From ISPConfig:
    Code:
    awstats conf folder: /etc/awstats
    awstats data folder: /var/lib/awstats
    awstats.pl script: /var/www/awstats/awstats.pl
    awstats_buildstaticpages.pl script: /usr/share/awstats/tools/awstats_buildstaticpages.pl
    
    As I can see from the error, awstats try to read awstats.conf from /usr/lib/cgi-bin/, but the correct awstats.conf (I guess it's correct) it's in /etc/awstats/ and it contains:
    http://pastebin.com/x9zeSq9Q

    Directory listing:
    Code:
    [[email protected] ~]# ls -al /usr/lib/cgi-bin/
    total 768
    drwxr-xr-x   5 root root   4096 Nov 19 00:11 .
    dr-xr-xr-x. 18 root root   4096 Nov 18 13:52 ..
    -rw-r--r--   1 root root   5226 Feb 15  2012 awdownloadcsv.pl
    -rw-r--r--   1 root root   8691 Feb 15  2012 awredir.pl
    -rw-r--r--   1 root root  61619 Nov 19 01:03 awstats.conf
    -rwxrwxrwx   1 root root 676647 Jul  9 22:59 awstats.pl
    drwxr-xr-x   5 root root   4096 Nov 18 13:52 lang
    drwxr-xr-x   2 root root   4096 Nov 18 13:52 lib
    drwxr-xr-x   3 root root   4096 Nov 18 13:52 plugins
    [[email protected] ~]# ls -al /var/www/awstats/
    total 712
    drwxr-xr-x   9 root root   4096 Nov 19 00:21 .
    drwxr-xr-x. 14 root root   4096 Nov 18 23:46 ..
    -rwxr-xr-x   1 root root   8691 Feb 15  2012 awredir.pl
    -rwxr-xr-x   1 root root 676647 Jul  9 22:59 awstats.pl
    drwxr-xr-x   3 root root   4096 Nov 18 13:49 classes
    drwxr-xr-x   2 root root   4096 Nov 17 23:24 css
    drw-rw-r--   9 root root   4096 Nov 17 23:24 icon
    drwxr-xr-x   2 root root   4096 Nov 17 23:24 js
    drwxr-xr-x   5 root root   4096 Nov 17 23:24 lang
    drwxr-xr-x   2 root root   4096 Nov 17 23:24 lib
    drwxr-xr-x   3 root root   4096 Nov 18 13:48 plugins
    [[email protected] ~]# ls -al /usr/share/awstats/tools/
    total 188
    drwxr-xr-x 5 root root  4096 Nov 18 13:53 .
    drwxr-xr-x 3 root root  4096 Nov 18 13:53 ..
    -rwxrwxrwx 1 root root 19750 Oct 17  2012 awstats_buildstaticpages.pl
    -rw-r--r-- 1 root root 26094 Dec 30  2009 awstats_configure.pl
    -rw-r--r-- 1 root root 12725 May  2  2010 awstats_exportlib.pl
    -rw-r--r-- 1 root root  5497 Jul 24  2006 awstats_updateall.pl
    -rw-r--r-- 1 root root 16466 Apr 17  2010 geoip_generator.pl
    -rw-r--r-- 1 root root   855 Dec 30  2009 httpd_conf
    -rw-r--r-- 1 root root 32706 Jan 17  2013 logresolvemerge.pl
    -rw-r--r-- 1 root root 27807 Jan  6  2013 maillogconvert.pl
    drwxr-xr-x 2 root root  4096 Nov 18 13:53 nginx
    -rw-r--r-- 1 root root  9800 May  2  2010 urlaliasbuilder.pl
    drwxr-xr-x 2 root root  4096 Nov 18 13:53 webmin
    drwxr-xr-x 2 root root  4096 Nov 18 13:53 xslt
    [[email protected] ~]#
    and some .txt files in /var/lib/awstats/
    My guess is that it has something to do with paths and/or permissions. Also, I don't know if DirCgi= and DirIcons= are correct.

    I hope you can help me sort this out. Thank you.

    L.E.: OK! I have overwrite the awstats.conf from /usr/lib/cgi-bin/ with the one from /etc/awstats/ and now I can access the stats page and see some datas, but still something it's broken. I can't see any image (logo, icons) so I think the paths from DirCgi and DirIcons are wrong. What should be there, taking into account my current dir structure? I really have no idea...
     
    Last edited: Nov 21, 2013
  2. lordimac

    lordimac New Member

  3. srijan

    srijan New Member HowtoForge Supporter

    Hi


    Please follow the thread for resolution.

    Br//
    Srijan
     
  4. lordimac

    lordimac New Member

    Sorry, but this is another Problem.

    My awstats.conf (Wheezy Default):
    Code:
    LogFile="/var/log/apache2/access.log"
    LogType=W
    LogFormat=4
    LogSeparator=" "
    SiteDomain=""
    HostAliases="localhost 127.0.0.1"
    DNSLookup=1
    DirData="/var/lib/awstats"
    DirCgi="/cgi-bin"
    DirIcons="/awstats-icon"
    AllowToUpdateStatsFromBrowser=0
    AllowFullYearView=2
    EnableLockForUpdate=0
    DNSStaticCacheFile="dnscache.txt"
    DNSLastUpdateCacheFile="dnscachelastupdate.txt"
    SkipDNSLookupFor=""
    AllowAccessFromWebToAuthenticatedUsersOnly=0
    AllowAccessFromWebToFollowingAuthenticatedUsers=""
    AllowAccessFromWebToFollowingIPAddresses=""
    CreateDirDataIfNotExists=0
    BuildHistoryFormat=text
    BuildReportFormat=html
    SaveDatabaseFilesWithPermissionsForEveryone=0
    PurgeLogFile=0
    ArchiveLogRecords=0
    KeepBackupOfHistoricFiles=0
    DefaultFile="index.php index.html"
    SkipHosts=""
    SkipUserAgents=""
    SkipFiles=""
    SkipReferrersBlackList=""
    OnlyHosts=""
    OnlyUserAgents=""
    OnlyUsers=""
    OnlyFiles=""
    NotPageList="css js class gif jpg jpeg png bmp ico rss xml swf"
    ValidHTTPCodes="200 304"
    ValidSMTPCodes="1 250"
    AuthenticatedUsersNotCaseSensitive=0
    URLNotCaseSensitive=0
    URLWithAnchor=0
    URLQuerySeparators="?;"
    URLWithQuery=0
    URLWithQueryWithOnlyFollowingParameters=""
    URLWithQueryWithoutFollowingParameters=""
    URLReferrerWithQuery=0
    WarningMessages=1
    ErrorMessages=""
    DebugMessages=0
    NbOfLinesForCorruptedLog=50
    WrapperScript=""
    DecodeUA=0
    MiscTrackerUrl="/js/awstats_misc_tracker.js"
    LevelForBrowsersDetection=2 
    LevelForOSDetection=2 
    LevelForRefererAnalyze=2 
    LevelForRobotsDetection=2
    LevelForSearchEnginesDetection=2
    LevelForKeywordsDetection=2
    LevelForFileTypesDetection=2
    LevelForWormsDetection=0 
    UseFramesWhenCGI=1
    DetailedReportsOnNewWindows=1
    Expires=0
    MaxRowsInHTMLOutput=1000
    Lang="auto"
    DirLang="/usr/share/awstats/lang"
    ShowMenu=1					
    ShowSummary=UVPHB
    ShowMonthStats=UVPHB
    ShowDaysOfMonthStats=VPHB
    ShowDaysOfWeekStats=PHB
    ShowHoursStats=PHB
    ShowDomainsStats=PHB
    ShowHostsStats=PHBL
    ShowAuthenticatedUsers=0
    ShowRobotsStats=HBL
    ShowWormsStats=0
    ShowEMailSenders=0
    ShowEMailReceivers=0
    ShowSessionsStats=1
    ShowPagesStats=PBEX
    ShowFileTypesStats=HB
    ShowFileSizesStats=0	
    ShowDownloadsStats=HB	
    ShowOSStats=1
    ShowBrowsersStats=1
    ShowScreenSizeStats=0
    ShowOriginStats=PH
    ShowKeyphrasesStats=1
    ShowKeywordsStats=1
    ShowMiscStats=a
    ShowHTTPErrorsStats=1
    ShowSMTPErrorsStats=0
    ShowClusterStats=0
    AddDataArrayMonthStats=1
    AddDataArrayShowDaysOfMonthStats=1
    AddDataArrayShowDaysOfWeekStats=1
    AddDataArrayShowHoursStats=1
    IncludeInternalLinksInOriginSection=0
    MaxNbOfDomain = 10
    MinHitDomain  = 1
    MaxNbOfHostsShown = 10
    MinHitHost    = 1
    MaxNbOfLoginShown = 10
    MinHitLogin   = 1
    MaxNbOfRobotShown = 10
    MinHitRobot   = 1
    MaxNbOfDownloadsShown = 10
    MinHitDownloads = 1
    MaxNbOfPageShown = 10
    MinHitFile    = 1
    MaxNbOfOsShown = 10
    MinHitOs      = 1
    MaxNbOfBrowsersShown = 10
    MinHitBrowser = 1
    MaxNbOfScreenSizesShown = 5
    MinHitScreenSize = 1
    MaxNbOfWindowSizesShown = 5
    MinHitWindowSize = 1
    MaxNbOfRefererShown = 10
    MinHitRefer   = 1
    MaxNbOfKeyphrasesShown = 10
    MinHitKeyphrase = 1
    MaxNbOfKeywordsShown = 10
    MinHitKeyword = 1
    MaxNbOfEMailsShown = 20
    MinHitEMail   = 1
    FirstDayOfWeek=1
    ShowFlagLinks=""
    ShowLinksOnUrl=1
    UseHTTPSLinkForUrl=""
    MaxLengthOfShownURL=64
    HTMLHeadSection=""
    HTMLEndSection=""
    MetaRobot=0
    Logo="awstats_logo6.png"
    LogoLink="http://awstats.sourceforge.net"
    BarWidth   = 260
    BarHeight  = 90
    StyleSheet=""
    color_Background="FFFFFF"
    color_TableBGTitle="CCCCDD"
    color_TableTitle="000000"
    color_TableBG="CCCCDD"
    color_TableRowTitle="FFFFFF"
    color_TableBGRowTitle="ECECEC"
    color_TableBorder="ECECEC"
    color_text="000000"
    color_textpercent="606060"
    color_titletext="000000"
    color_weekend="EAEAEA"
    color_link="0011BB"
    color_hover="605040"
    color_u="FFAA66"
    color_v="F4F090"
    color_p="4477DD"
    color_h="66DDEE"
    color_k="2EA495"
    color_s="8888DD"
    color_e="CEC2E8"
    color_x="C1B2E2"
    LoadPlugin="hashfiles"
    ExtraTrackedRowsLimit=500
    Include "/etc/awstats/awstats.conf.local"
    awstats.conf.local:
    Code:
    LogFormat=1
    awstats.domain.tld.conf (Generated by ISPConfig):
    Code:
    Include "/etc/awstats/awstats.conf"
    LogFile="/var/log/ispconfig/httpd/domain.tld/yesterday-access.log"
    SiteDomain="domain.tld"
    HostAliases="www.domain.tld localhost 127.0.0.1 wordpress.domain.tld www.wordpress.domain.tld"
    Log Folder domain.tld:
    Code:
    drwxr-xr-x  2 root root 4,0K Apr 21 02:11 .
    drwxr-xr-x 24 root root 4,0K Apr 19 12:43 ..
    -rw-r--r--  1 root root 1,6K Apr 21 00:33 20140419-access.log.gz
    -rw-r--r--  1 root root  14K Apr 20 21:50 20140420-access.log
    -rw-r--r--  1 root root  979 Apr 21 08:30 20140421-access.log
    lrwxrwxrwx  1 root root   19 Apr 21 02:11 access.log -> 20140421-access.log
    -rw-r--r--  1 root root  21K Apr 21 08:09 error.log
    -rw-r--r--  1 root root  33K Apr 20 00:30 webalizer.conf
    lrwxrwxrwx  1 root root   53 Apr 21 00:36 yesterday-access.log -> /var/www/clients/client1/web1/log/20140420-access.log
    And my fstab:
    Code:
    # <file system>	<mount point>	<type>	<options>	<dump>	<pass>
    /dev/md1	/	ext4	errors=remount-ro,relatime,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0	0	1
    /dev/sda2	swap	swap	defaults	0	0
    /dev/sdb2	swap	swap	defaults	0	0
    proc		/proc	proc	defaults		0	0
    sysfs		/sys	sysfs	defaults		0	0
    tmpfs		/dev/shm	tmpfs	defaults	0	0
    devpts		/dev/pts	devpts	defaults	0	0
    /var/log/ispconfig/httpd/domain.tld /var/www/clients/client1/web1/log    none    bind,nobootwait    0 0
    ...
     
    Last edited: Apr 21, 2014
  5. lordimac

    lordimac New Member

    Don't know why, but it's working now. Maybe there was not enough data available yesterday.
     

Share This Page