Awstats not working with nginx on debian with lets encrypt

Discussion in 'Installation/Configuration' started by LAKSHA, Apr 2, 2017.

  1. LAKSHA

    LAKSHA Member HowtoForge Supporter

    I had used https://www.howtoforge.com/tutorial/perfect-server-debian-jessie-nginx-bind-dovecot-ispconfig-3.1/
    and now while setting up password of awstat and using it to login . i get 404 error on https://mydomain.tld/stats i also tried it without https and it gives the same error .
    AWSTATS
    I do see the build static page pl file at /usr/share/awstats/tools and i do see stats folder inside the web folder of my tld.
    awstats conf folder /etc/awstats
    awstats data folder /var/lib/awstats
    awstats.pl script /usr/lib/cgi-bin/awstats.pl
    awstats_buildstaticpages.pl script /usr/share/awstats/tools/awstats_buildstaticpages.pl
    WORDPRESS
    following is my wp-config
    define('FORCE_SSL_ADMIN', true);
    $_SERVER['HTTPS']='on';

    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    define( 'WP_ALLOW_MULTISITE', false );
    define ('FS_METHOD', 'direct');
    ISPCONFIG
    in my ispconfig for mydomain.tld there is not redirect rule or a box checked for redirect from http to https.

    Any help will be highly appreciated and endorsed
     
  2. LAKSHA

    LAKSHA Member HowtoForge Supporter

    I do see all the stats files in stat folder and all the web traffic in ispconfig 3 panel but when i open the stats and use my passwords it just loads the main frame and the inner frame does not load and throws 404 error. :-( sos to @till :confused: please help
     
  3. LAKSHA

    LAKSHA Member HowtoForge Supporter

    i changed the path to access log in the awstat.domain.tld.conf file here /etc/awstats but still cannot see the stats
     

Share This Page