Awstats just stopped working two days ago.

Discussion in 'General' started by pvanthony, Oct 10, 2012.

  1. pvanthony

    pvanthony Member

    Hi,

    I am really lost here.

    Awstats was working find until the 7th of October 2012. Now it is not updating.

    After going into the http://www.example.com/stats, I can see the stats page. It states that the page has been updated. But there are no records after the 7th of October 2012.

    Run the daily cron job and the server cron job and there are no errors.

    Is there any other place I can check for errors?

    Checked into the log folder and the log files are there but seems that they have not been processed and tarred. The yesterday_log link is still pointing to 8th October 2012.

    What can be wrong? What can I do to solve this?

    P.V.Anthony
    P.V.Anthony
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you find any cron errors about the cron_daily.sh script in the syslog in /var/log/?
     
  3. pvanthony

    pvanthony Member

    Dear Till,

    Thank you very much for replying.

    I have run this on cmd line.
    /usr/local/ispconfig/server/cron_daily.sh

    and got the response "finished" without any errors. Was running another terminal with the cmd "tail -F /var/log/messages" and there was no errors.

    Is there anything else I can check?

    Currently running CentOS 6.3, nginx, dovecat with ispconfig 3.0.4.6.

    P.V.Anthony
     
  4. pvanthony

    pvanthony Member

    Went into the logs an noticed that it did update the awstats but it is still two days off. So I think the script is working but two days off.

    Here is the listing of the last few files of the logs. Observe the dates and the link file named yesterday.

    -rw-r--r-- 1 root root 43K Oct 11 00:02 20121008-access.log.gz
    -rw-r--r-- 1 nginx root 478K Oct 9 23:51 20121009-access.log
    -rw-r--r-- 1 nginx root 880K Oct 10 23:59 20121010-access.log
    -rw-r--r-- 1 nginx root 1.6K Oct 11 00:15 access.log
    -rw-r--r-- 1 nginx client6 70K Oct 11 00:10 error.log
    lrwxrwxrwx 1 root root 54 Oct 11 00:13 yesterday-access.log -> /var/www/clients/client6/web10/log/20121009-access.log

    Tried running the daily.sh again but nothing changed.

    What could be the problem?

    P.V.Anthony
     
  5. schickel

    schickel New Member

    This thread seems to be old not solved.

    I got this problem also after upgrading my server to Ubuntu 13.04.

    I also get no errors in any log, but awststats did not update stats and did not work. Webalizer is working but it is very...

    So, is there anyone who can say something about this?

    I have the actual ISPConfig version on Ubuntu 13.04
     
  6. schickel

    schickel New Member

  7. jaypabs

    jaypabs Member

    I have the same problem. It's already June 26, but the awstats last visit says: 24 Jun 2013

    awstats Last Update says: 26 Jun 2013 - 00:30

    Any idea?
     
  8. schickel

    schickel New Member

  9. jaypabs

    jaypabs Member

  10. schickel

    schickel New Member

    1. Open /usr/lib/cgi-bin/awstats.pl

    2. search sub UnCompileRegex (in my awstatspl is this in line 7820)

    3. replace
    Code:
    shift =~ /\(\?[-\w]*:(.*)\)/;
    
    with
    Code:
     
    shift =~ /\(\?[-^\w]*:(.*)\)/;
    
    Start awstats manually or wait for cronjob.
     
    Last edited: Jun 26, 2013

Share This Page