AWStats Installer

Discussion in 'Tips/Tricks/Mods' started by jnsc, Oct 6, 2006.

  1. Burge

    Burge New Member HowtoForge Supporter

    ah, there is no dir sounds like awstats under /etc/

    thats explain the errors from test.

    So i have to install awstats by apt ?
  2. jnsc

    jnsc rotaredoM Moderator

    mkdir /etc/awstats && cd /etc/awstats && wget
    should be enough.

    I will have a look at the installer, but at the first look, it should have created the directory.
  3. Burge

    Burge New Member HowtoForge Supporter

    ok, done.

    now i have returned the input from the post befor.

    vvv-net:/etc/awstats# /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php
    Main HTML page is ''.
    And now i have stats wenn use the url www.client.tld/awstats

    Wow i thank you for help. So know i can read about to install geo location db and the other nice thinks for awstats.
    Last edited: Sep 7, 2009
  4. jnsc

    jnsc rotaredoM Moderator

    Ok, I found the problem, the dir was only created on new install,not on upgrades. I corrected it.

    you can also use www.client.tld/stats which should point to AWStats if you choose AWStats as statistics program.
  5. Burge

    Burge New Member HowtoForge Supporter

    yes is works to.

    Thanks a lot. Adtional if know some links for me to "read in" plugins for awstats i will thanks to.
  6. jnsc

    jnsc rotaredoM Moderator

  7. Burge

    Burge New Member HowtoForge Supporter

    hi, its me again

    one problem is keeping

    I can see the stats but all links to images are wrong. How can i adjust the link for awstats to show his grafics correctly.

    URL (44)Fehlerhafte ZugriffeVerweise /icon/other/awstats_logo6.png5http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/browser/opera.png4http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/clock/hr10.png4http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /stats4- /robots.txt3- /icon/flags/ip.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/he.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/hh.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/hk.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/browser/firefox.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/hp.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/mime/image.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/os/win.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/clock/hr6.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/mime/php.png3http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/vp.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/hx.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/other/vu.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/mime/jscript.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/clock/hr8.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /stats/index.html2- /icon/clock/hr4.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/clock/hr2.png2http://www.client.tld/stats/awstats.www.client.tld.2009-09.html /icon/os/unknown.png
  8. jnsc

    jnsc rotaredoM Moderator

    Add this to your apache configuration file
    ### AWStats Section ###
    Alias /icon "/home/admispconfig/ispconfig/tools/awstats/wwwroot/icon/"
    ### End of AWStats Section ###
  9. psychop

    psychop New Member

    Well since this thing is going on from 2006 some of us still have problems :)

    When upgraded awstats to latest verion and ISPConfig is 2.35, awstats worked only once. Nothing happened since 15.april.

    cron job is created, when running it manualy no errors but also nothing happenes.

    6 domains are hosting and all worked only once. Conf files are created and even first time it created all .html files in webX dir. So old statistics for 04 can be seen but nothing new.

    Tnx for help all :)
  10. jnsc

    jnsc rotaredoM Moderator

    what do you mean by
    . Don't you use the bundled version of awstats?

    Does the stats work for this websites with webalizer? do you have some hits in the web.log?
  11. psychop

    psychop New Member

    Latest version ment from awstats page: awstats-6.95.tar.gz

    Log files are created ok, even the 04,05, (month) dirs.

    Awstats dir has new "" file created on 11.05.2010

    Changed statistics for 1 website to webalizer, restarted server ran cronjob: /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null

    and no changes to this site directory.

    Should I try something else??
    Last edited: May 15, 2010
  12. psychop

    psychop New Member

    Today I checked this site that statistics was changed to webalizer and awstats created new html files and it actualy worked.
    Weird is that statistics was set to webalizer, but awstats updated.

    When loging in it was not possible. Got error 403, then changing back to awstats statistics login was succesful and new sttistics was there.

    Any clues?
    Last edited: May 16, 2010
  13. jnsc

    jnsc rotaredoM Moderator

    Did you use the installer? As mixing the installer with the version included in ISPConfig (Warning on top of the page is for me the only case where this could happen.
  14. psychop

    psychop New Member

    So what do u suggest???

    Reinstall all??
  15. jnsc

    jnsc rotaredoM Moderator

    The question was did you install the package after installing ISPConfig 2.2.35? if yes "updating" ISPConfig would normally be sufficient. (by updating I mean reinstalling latest ISPConfig version without whipping everything)
  16. psychop

    psychop New Member

    Ok gonna try to reinstall ISPConfig.

    Will report if it helped.
  17. psychop

    psychop New Member

    Well reinstalled ISPConfig.
    When running cronjob now get this:

    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

    When checking in yast it is no awstats installed. What now? What package to use now?
    Last edited: May 18, 2010
  18. jnsc

    jnsc rotaredoM Moderator

    This error occurs because you are in a directory that does not exist anymore (the ISPConfig install dir) a simple cd solves this "problem". As AWStats is bundled with ISPConfig, you do not need to install it (so you will not see it in yast)
  19. psychop

    psychop New Member

    Today checked all again and it's a miracle... it works (for now) :)

    One more thing: howto skip local ( page access count? I know i have to write it under Skip... but in which file couse don't know which conf it uses. Should it be in awstats.shared.conf ?

    Tnx 4 help!
    Last edited: May 19, 2010
  20. jnsc

    jnsc rotaredoM Moderator

    If you want to skip it for all hosts, yes it is awstats.shared.conf

Share This Page