AWStats Installer

Discussion in 'Tips/Tricks/Mods' started by jnsc, Oct 6, 2006.

  1. matrixn

    matrixn New Member

    hello,
    first i want to thank about the awstats plugin and secondly i wish to ask if is possible to use the awstats mail statistics... i take a look at the awstats plugin but it does not contain the mail modules...

    Is there any possibilities to integrate the mail info in the future...?


    Thanks
     
  2. dennisuello

    dennisuello New Member

    I followed the instructions here http://jnsc.ch/ispconfig.php

    When I run "/root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php" I get no errors, but also no data generated, awstats folders were created in all sites, but empty except for .htaccess file.
     
  3. dvazart

    dvazart New Member

    Yeahh... the same thing here !!! :(
     
  4. jnsc

    jnsc rotaredoM Moderator

    Are your webalizer stats generated corectly? do you have a web.log file in you log directory?
     
  5. dennisuello

    dennisuello New Member

    Webalizer works, but only after I updated to 2.2.29 from 2.2.6. I have no web.log in /var/log. My Webalizer uses /var/log/httpd/access_log, I believe.
     
  6. jnsc

    jnsc rotaredoM Moderator

    sorry, i was talking about /var/www/webXX/log/web.log
     
  7. dvazart

    dvazart New Member

    I'm using ISPConfig 2.2.29 but i don't have a web.log file in my web directory, i only have an error.log file...

    ls /var/www/web1/log/
    Code:
    error.log
    And i think is normal when i look this :

    nano /etc/apache2/vhosts/Vhosts_ispconfig.conf
    Code:
    <VirtualHost 192.168.1.200:80>
    ServerName www.daniel.org:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web2/web
    ServerAlias daniel.org
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
      RewriteRule .* - [F]
    </IfModule>
    </VirtualHost>
    
    So... thats may be a bug in ISPConfig 2.2.29 are you forget to include this file in the vhost config ?? OR you have to modify your AWstats script....

    --------- EDIT -----------

    I found this... In ISPConfig 2.2.27 (awstats and webalizer are working ok) :

    ls -l log/
    Code:
    total 4
    drwxr-xr-x 3 web2_daniel web2 4096 2008-11-19 00:30 2008
    -rw-r--r-- 1 web2_daniel web2    0 2008-11-18 09:35 error.log
    lrwxrwxrwx 1 web2_daniel web2   45 2008-11-19 00:30 web.log -> /var/www/www.daniel.local/log/2008/11/web.log
    
    But in ISPConfig 2.2.29 Nothing (no awstats, no webalizer, no web.log).

    ISPConfig 2.2.27 :

    grep -r "web.log" /root/
    Code:
    /root/ispconfig/scripts/shell/logs.php:        return "$webroot/$virtual_host/log/$jahr/$monat/web.log";
    /root/ispconfig/scripts/shell/logs.php:                if(@readlink("$webroot/$virtual_host/log/web.log") != get_filename($virtual_host)) {
    /root/ispconfig/scripts/shell/logs.php:                        if(is_link("$webroot/$virtual_host/log/web.log")) @unlink("$webroot/$virtual_host/log/web.log");
    /root/ispconfig/scripts/shell/logs.php:                        @symlink(get_filename($virtual_host),"$webroot/$virtual_host/log/web.log");
    
    ISPConfig 2.2.29 :

    grep -r "web.log" /root/
    Code:
    /root/ispconfig/scripts/shell/logs.php:        return "$webroot/$virtual_host/log/$jahr/$monat/web.log";
    /root/ispconfig/scripts/shell/logs.php:                if(@readlink("$webroot/$virtual_host/log/web.log") != get_filename($virtual_host)) {
    /root/ispconfig/scripts/shell/logs.php:                        if(is_link("$webroot/$virtual_host/log/web.log")) @unlink("$webroot/$virtual_host/log/web.log");
    /root/ispconfig/scripts/shell/logs.php:                        @symlink(get_filename($virtual_host),"$webroot/$virtual_host/log/web.log");
    
    All seems to be OK.... no ?
     
    Last edited: Jan 30, 2009
  8. jnsc

    jnsc rotaredoM Moderator

    I don't recall exactly how the web.log is generated, and I don't have access to a server right now. Maybe Falko or Till can help here. Isn't the web.log generated by a splitlog script? if yes what is the name of the script?

    Thank's
    Jonas
     
  9. dvazart

    dvazart New Member

    :D Sorry.... not seen this:
    crontab -l
    Code:
    30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    Everythig are working ok !!! :p
     
  10. YuKu

    YuKu New Member

    I like the stats a lot, however when I put try to import old stats from my old server (awstats 6.4) and I run the cron job I don't get any new stats, just the new one from the ispconfig server

    running ubuntu 9.04 with ispconfig 2.2.32

    I've put the files in /web/awstats when I log in with ftp or should they be placed in other directory, this was place where other (new) statsfile was.
     
  11. YuKu

    YuKu New Member

    OK I think it just works a little different but when I open the stats page in the browser I do get the old stats included.

    is there a way to get it to look more like http://www.nltechno.com/awstats/awstats.pl?config=destailleur.fr

    what I mean is now I don't get a sidebar on the left or the option to choose month/year

    another thing I don't get to work is the icons/images.
    I've placed the alias in apache2.conf and restarted the service (even entire server) but still don't get them

    hope someone can point me in the right direction
     
  12. jnsc

    jnsc rotaredoM Moderator

  13. Burge

    Burge New Member HowtoForge Supporter

    Hi,

    In the latest installer for the ispconfig2 is an awstats packet includet so i read.

    After the update (it works fine like everytime) i selectet for one webpage awstats als stats aplication. I saw that a new cronjob ist added by the update and the cronjob create the dir /awstats/ in client directory.

    But in this dir are only a index.html and of course the htaccess file.
    So the question is must i installed aditional packests or what make i wrong?

    So please help me

    Greets Burge
     
  14. jnsc

    jnsc rotaredoM Moderator

    No, nothing more is needed, just wait until 4 am, and if the website got some visits on the day before, you will see the statistics.
     
  15. Burge

    Burge New Member HowtoForge Supporter

    thanks for reply so i have wait, and the website has some access but in a subfolder but i dont think thats the problem.

    So and at this moring i still have the same result. In the awstats folder are only a index file and the htaccess.

    Where can i look the resolve this problem?

    thanks Burge
     
  16. jnsc

    jnsc rotaredoM Moderator

    is the web.log file present in the log directory of your website? does it have entries for yesterday?
     
  17. Burge

    Burge New Member HowtoForge Supporter

    yes there is a symlink to web.log file and yes yesterday was writen access in this file.

    But my Awstats diretory is still have only the 2 files as know as index and htaccess.

    But on the other way i have seen in the other web diretorys they i donĀ“t touch after the update hab now an webanalizer dir und off course a stats dir.

    Content seams like the same.
     
  18. jnsc

    jnsc rotaredoM Moderator

    What is the output of this command
    Code:
    /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php
    did webalizer work previously with this site?
     
  19. Burge

    Burge New Member HowtoForge Supporter

    first the output
    PHP:
    vvv-net:~# /root/ispconfig/php/php /root/ispconfig/scripts/shell/awstats.php

    Warningfopen(/etc/awstats/awstats.www.vvv-net.de.conf): failed to open streamNo such file or directory in /root/ispconfig/scripts/shell/awstats.php on line 192

    Warning
    fwrite(): supplied argument is not a valid stream resource in /root/ispconfig/scripts/shell/awstats.php on line 193

    Warning
    fclose(): supplied argument is not a valid stream resource in /root/ispconfig/scripts/shell/awstats.php on line 194

    Warning
    chmod(): No such file or directory in /root/ispconfig/scripts/shell/awstats.php on line 195
    Error
    Couldn't open config file "awstats.www.vvv-net.de.conf" nor "awstats.conf" after searching in path "/home/admispconfig/ispconfig/tools/awstats/wwwroot/cgi-bin,/home/admispconfig/ispconfig/tools/awstats/tools/,/etc/awstats,/usr/local/etc/awstats,/etc,/etc/opt/awstats": No such file or directory.
    vvv-net:~#
    and second, yes it works all time fine with webanalizer.
     
  20. jnsc

    jnsc rotaredoM Moderator

    ok, we are getting closer, do you have an /etc/awstats/ directory? and if yes what is it's contents, and it's permissions?
     
    Last edited: Sep 7, 2009

Share This Page