awstats - Error: SiteDomain parameter not defined in your config/domain file

Discussion in 'Installation/Configuration' started by cbj4074, Jun 21, 2013.

  1. cbj4074

    cbj4074 HowtoForge Supporter

    Hello,

    I installed most of my software before installing ISPConfig; this is usually the preferred order-of-operations, as I understand it, which makes sense in that it allows ISPC to determine what is installed and configure itself accordingly. Among the packages I installed was awstats.

    The problem I'm having is that every 10 minutes I receive an email that results from a cron job that does:

    Code:
    [ -x /usr/share/awstats/tools/update.sh ] && /usr/share/awstats/tools/update.sh
    
    The resultant error is:

    Code:
    Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.
    Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).
    
    Do I simply need to disable this cron job, e.g., because ISPC calls its own job to compile stats?

    Or is some other measure required? I don't remember having to perform any configuration of awstats on servers that I've built in the past with ISPC.

    I have ISPC 3.0.5.2 and haven't modified any of the default values relating to Web-stats in the GUI.

    Thanks for any help!
     
  2. till

    till Super Moderator

    Yes, The global awstats cronjob has to be disabled.
     
  3. cbj4074

    cbj4074 HowtoForge Supporter

    Thanks, Till.

    I seem to have two awstats cron jobs:

    Code:
    [ -x /usr/share/awstats/tools/update.sh ] && /usr/share/awstats/tools/update.sh
    
    [ -x /usr/share/awstats/tools/buildstatic.sh ] && /usr/share/awstats/tools/buildstatic.sh
    
    Should both of these be disabled? Or only update.sh (as that is the script that is throwing errors)?
     
  4. mintess

    mintess New Member

    Can anybody please answer this?
     
  5. till

    till Super Moderator

    Yes, both have to be disabled.
     

Share This Page