Avoid https://name.tld:81 for phpmyadmin and roundcubemail

Discussion in 'Installation/Configuration' started by wuptydu, Mar 2, 2008.

  1. wuptydu

    wuptydu New Member

  2. jorizzzz

    jorizzzz New Member

    What i've done is created a new co-domain for my website and set it to forward to my phpmyadmin and roundcubemail

    Now if i go to webmail.<mydomain>.com, it automatically redirects me to https://<mydomain>.com:81/roundcubemail
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. wuptydu

    wuptydu New Member

    till : It looks nice but i can't see how to transfer this for webmail and phpmyadmin and make it work on any site added in ISPConfig.

    Can you give me a hint ?
  5. falko

    falko Super Moderator ISPConfig Developer

    I think all you have to do is adjust the ProxyPass and ProxyPassReverse lines.
  6. TomC

    TomC New Member

    The Howto looks great, sounds exactly like what I was searching for.

    Question: After configuring the ProxyPass, is there a way to disable remote access to port 81?
  7. TomC

    TomC New Member

    Hi All,

    yesterday night I spent some time to configure my ISPConfig so that it would listen to port 80 - as described in the Howto mentioned above by Till.

    Some comments on that:

    1. I don't know why, but I had to adjust the VirtualHost settings:

    <VirtualHost [B]111.222.333.444:80[/B]>
            ServerName ispconfig.example.com[B]:80[/B]
    Maybe it's because my machine runs on a Virtuozzo virtual server?

    2. The performance when addressing ISPConfig via Proxy is awful. Every now and then I get proxy errors because of failed DNS requests, etc. So it looks that I might have another problem on my system that has to do with the resolver?!

    3. When it comes to system configuration, I'd rather use SSL. So did you think about adjusting the howto for a SSL configuration?!

    4. Once I can reach ISPConfig through my main Apache, there is no need to have the ISPConfig-Apache publically accessible. Is there a way to make this webserver a purely internal machine that is only accessible by proxying through the main webserver?

    I'd love to read more about these subjects. Thanks loads in advance!
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/resolv.conf?
  9. TomC

    TomC New Member

    Hi Falco,

    the reason for the performance problems were indeed a bad nameserver at 1und1. After correcting the entries in resolv.conf everything worked fabulous.

    Point 3 is also solved - managed to reconfigure apache2 to forward from an ssl-Connection.

    Point 4 is still of interest. How would you block a connect from !=localhost to access ispconfig on port 81?

  10. Hans

    Hans Moderator ISPConfig Developer

    Last edited: Mar 8, 2008
  11. wuptydu

    wuptydu New Member

  12. wuptydu

    wuptydu New Member

  13. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log?

Share This Page