autoresponder problems

Discussion in 'Installation/Configuration' started by mbianchi, Jul 25, 2013.

  1. mbianchi

    mbianchi New Member

    Hi all,
    I'm running isconfig 3.0.4.6 on CentOs 6.3
    I had a problem with the autoresponder, I just wanted to change it's behaviour and so changed the autoresponder.master file.
    When I made my changes to add some option to the mailbot command, the autoresponder stopped working. No I'm back with the exact same master file as before but the autoresponder still does not work.
    What do I have to do? There are no logs to see what is happening, it is all working except the autoresponder.
    This is the content of my autoresponder.master file (same as the installation one):

    `test -f {vmail_mailbox_base}/mailfilters/$HOST/$USER/.vacation.msg && exit 1 || exit 0`
    if ($RETURNCODE==1)
    {
    {
    if (!/^List-Unsubscribe:.*/:h )
    {
    if (!/^X-Spam-Flag: YES/:h )
    {
    NOW=time
    if ({start_date} lt $NOW && {end_date} gt $NOW)
    {
    RESPOND="{vmail_mailbox_base}/mailfilters/$HOST/$USER/.vacation.msg"
    RESPONDDB="{vmail_mailbox_base}/mailfilters/$HOST/$USER/.vacation.lst"

    # The following must be one contiguous line
    cc "| mailbot -t $RESPOND -d $RESPONDDB -c 'UTF-8' -D 1 \
    -A 'From: $RECIPIENT' -s 'Out of Office: from $RECIPIENT' \
    /usr/sbin/sendmail -t -f ''"
    }
    }
    }
    }
    }

    Thanks in advance
     
  2. mbianchi

    mbianchi New Member

    Ok no problems, it's working now, I just turned off and back on the autoresponder option in the mailbox manager.
    For those who want to have a clean autoresponse with only your message and not the original message, just add
    -T reply -N -S ''
    to the mailbot command like this:
    Code:
    # The following must be one contiguous line
    cc "| mailbot -T reply -N -S '' -t $RESPOND \
    -d $RESPONDDB -c 'UTF-8' -D 1 \
    -A 'From: $RECIPIENT' -s 'Out of Office: from $RECIPIENT' \
    /usr/sbin/sendmail -t -f ''"
     

Share This Page