Autoresponder problems

Discussion in 'Installation/Configuration' started by jtheed, Dec 22, 2010.

  1. jtheed

    jtheed Member HowtoForge Supporter

    ISPCONFIG 3.0.3.1 and previous apparently.

    Autoresponder will send proper response message to any domain on the same server but when sending to an outside server, it sends it to the following:
    sent vacation response to <SRS0+1293045773.53324.was1-mh214=540f3e7f010cdcd3e7de752bfa53affb2d3450b6=gma...>
    There are several of the above entries but to different addresses.

    The above is in the mail log there is nothing in the line past the =gma...> and the messages are not being received by the intended recipient. This is a major problem because we will be closed for the next 10 days and no one is getting our Autoresponse message outside of our own server.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The autoresponses are not generated by ispconfig, ispconfig writes just the text message that shall be send as response to a file. Autoresponse messages are generated by either maildrop or dovecot deliver, depending on your system configuration.
     
  3. jtheed

    jtheed Member HowtoForge Supporter

    Ok, that I understand, but why if it is sent to a domain on the same server, it gets sent to [email protected] but when the server is somewhere else, like gmail for instance, it sends it differently and is probably rejected as it never shows up at the users mailbox?
    I am using Dovecot with sieve set as the mailfilter syntax.

    Here is what I see in the log.
    Dec 22 21:17:21 global1 deliver([email protected]): msgid=<[email protected]>: sent vacation response to <SRS0+1293070618.24219.was1-mh215=540f3e7f010cdcd3e7de752bfa53affb2d3450b6=gma...>

    The above is an auto reply sent to a gmail account and never makes it to the user that it was sent to.

    Dec 22 21:26:49 global1 deliver([email protected]): msgid=<[email protected]>: sent vacation response to <[email protected]>

    The above is an auto reply sent to an account on the same server that is sending the autoresponse, but a different domain name. This autoresponse gets received
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You should compare the headers of the email that was sent from gmail to a email that was sent ftom another server to trigger the auto reply. maybe gmail has a different header formatting or so which is not understand by the dovecot sieve autoresponder.
     
  5. jtheed

    jtheed Member HowtoForge Supporter


    I just used gmail as an example. We get emails from many different servers that are orders from our customers and none of them are getting the autoresponse message.

    More examples of messages received from outside my server, there are hundreds more in the log:
    Dec 8 09:28:03 global1 deliver([email protected]): msgid=<[email protected]ank.corp>: sent vacation response to <SRS0+1291818460.20390.tex1-mh314=b707eb94cc96c2227105XXXXXXX44c399782688f1=wel...>

    Dec 11 08:50:59 global1 deliver([email protected]): msgid=<[email protected]>: sent vacation response to <SRS0+1292075432.78213.was1-mh215=fbe4d59adf165eXXXXXXXXXa3f17b4784b06fff9=not...>

    Dec 20 20:51:29 global1 deliver([email protected]): msgid=<[email protected]>: sent vacation response to <SRS0+1292896270.41769.was1-mh215=3a8586c1a5485090d0b692586e1d8d1a2290afa6=att...>


    Below, the domains are on my server:
    Dec 20 11:01:46 global1 deliver([email protected]): msgid=<[email protected]>: sent vacation response to <[email protected]>

    Dec 22 21:26:49 global1 deliver([email protected]): msgid=<[email protected]>: sent vacation response to <[email protected]>

    As you can see, if the message comes from outside the server, the autoresponse does not go back out properly, no matter who it comes in from.

    This has been this way since this was newly installed a few months ago and before the 3.0.3.1 update, I just didn't know it as I only tested it from the same domain.

    This is on a Debian 5.0 install.
     
    Last edited: Dec 23, 2010
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont mean the lines from the logfile. Please check the headers of the received messages with your email client. It seems that the dovecot sieve autoresponder uses a wrong line of the google message as to address.
     
  7. jtheed

    jtheed Member HowtoForge Supporter

    You pretty much nailed it Till. It's not gmail causing the problem, but the Spam Service that we use, it is changing the return path in the message headers. It worked with ISPConfig 2.2 and Courier, so I am not sure if the change is in ISPConfig 3 or Dovecot, what do you think?

    I've changed our DNS to point directly to our mail server instead of going thru theirs (GFI MaxMailProtection Server) for the duration. I'll have to wait a bit for the update to get around to see if it actually solves the problem, but I think this is it.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2 uses a completely different mailsystem and the autoresponder in ispconnfig 2 is a procmail recipe that is manually developed by us. Such a procmail recipe will not work only on servers which use linux system users and not modern systems with virtual users like in ispconfig 3. You might want to ask the company that runs your spam protection software if they can disable returnpath changes.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Another option might be to write a sieve script that replaces the address in the returnpath with the from address and to add this script before the autoresponder is aclled. But I dont know if this is possible at all.
     
  10. jtheed

    jtheed Member HowtoForge Supporter

    I was able to contact the Spam Server support and they turned off SPF on their end and corrected the problem.

    Thanks for your Time Till, I appreciate it.

    Have a Great Holiday!
     

Share This Page