autoresponder problem

Discussion in 'Installation/Configuration' started by createch, May 29, 2010.

  1. createch

    createch ISPConfig Developer ISPConfig Developer

    Hi All,

    Recently it is found that the autoresponder doesn't send out email when the autoresponder checkbox is ticked.

    The following tests have been made:
    1. send an email to that particular email account
    2. check the .vacation.cache and I found that the sender email is there

    There is no problem in sending/receiving mail or mail forwarding. The problem is only no email seems to be sent out by the autoresponder function.

    Anyone has experience on how to troubleshoot it ? Thanks in advance.

    My Server Configuration: Fedora Core 12 server with ISPConfig 2.2.35 installed.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The email is sent out only once, so if you send a second time to that address, you won't receive an autoresponder message.
     
  3. createch

    createch ISPConfig Developer ISPConfig Developer

    Hi Falko,

    Thanks for your reply --- but the autoreply has never been received, not even the 1st time when the user receive an incoming email from that user.

    This is a quite interesting thing because it only happens in the Fedora 12 Core system, and actually as I said the Fedora 12 Core system, if installed with ISPConfig 2, will have some strange problem (e.g. quota [space used] always display 0).

    Createch
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What does the .procmailrc file of that account look like? Any errors in your mail log?
     
  5. createch

    createch ISPConfig Developer ISPConfig Developer

    Problem solved !

    Thanks for your reminder, I checked the maillog and found the following error

    cannot write to /var/spool/clientmqueue, permission denied (something like that)

    I checked and compared the ownership and permission of this directory with another server, and then corrected the permission of this directory and it works magically ! (Actually I almost want to reinstall the server but now it saved me lot of time)
     
  6. matej

    matej New Member

    I have same problem.
    I've set-up autoresponder. In the
    /var/www/web_home/.procmailrc I have:

    INCLUDERC=/var/www/web_home/user/username/.autoresponder.rc

    in the user home direcotry I have .vacation.msg and when I send mail to this user, my e-mail is added to .vacaction.cache, but I dont' get any return mail.

    I also don't get anny error in mail/info or mail/errors log.

    Thanks for help in advance.
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in the mail log when the return mail should be sent?
     
  8. matej

    matej New Member

    Nothing special. It just says that mail is delivered to mailbox...

    Jul 8 14:12:14 jona postfix/qmgr[19894]: 4AB9119AD63: from=<matej@pohorje.net>, size=3341, nrcpt=1 (queue active)
    Jul 8 14:12:14 jona postfix/local[20941]: 4AB9119AD63: to=<matejoor@mail2.pohorje.net>, orig_to=<matejoor@familylab.si>, relay=local, delay=0.12, delays=0.05/0/0/0.06, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jul 8 14:12:14 jona postfix/qmgr[19894]: 4AB9119AD63: removed
     
    Last edited: Jul 8, 2010
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is matejoor@mail2.pohorje.net the account that should receive the autoresponder message, or is it the account for which you set up the autoresponder?
     
  10. matej

    matej New Member

    matejoor is account which I set up the autoresponder.
    Sender (which should receive autoresponder message) is matej@pohorje.net
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    One reason I see is that an autoresponder is sent only once to an account. Maybe matej@pohorje.net sent an email to matejoor@mail2.pohorje.net before and got an autoresponder message back?
     
  12. matej

    matej New Member

    No, autorespond message is not sent back. Even first time. Sender adress is added to .vacation.cache but response mail is not sent.

    Which service is reponsible for createing out-of-offce reply (to put maybee some more detailed logging options ON?)?
    I have another server with same postfix configuration (same master.cf, main.cf) where out-of-office replying works normaly (so I assume that postfix configuration is not question).

    Thanks for additional help.

    Matej
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you compare the parmissions of the directories where .procmailrc is located on both servers?
     
  14. matej

    matej New Member

    Permisions of both directories (/var/www/www.domain.com/users/username/) are same
    rwxr-x-rx
    and persmision of .procmailrc is (rw-r--r--)
     
  15. nicopingu

    nicopingu New Member

    same problem here under ispconfig 3 / Ubuntu 10.04 LTS

    A has autoresponse activated with a message and a valid vacation date.
    A mailbox has .vacation.msg and .autoresponder

    nothing in mail log except the e-mail sent from B to A is delivered. But nothing about autoresponse message.

    POP3/IMAP Daemon : dovecot
    Mailfilter Syntax : sieve

    is it a problem with mailfilter syntax?
     
  16. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do all directories from /var up to /var/www/www.domain.com/users/username/ have rwxr-x-rx permissions?
     
  17. matej

    matej New Member

    yes. all directories have same permisions (but diferent owner).
    As I said, .vacation.cache file is witten (added email address from sender), but no reply mail.
     

Share This Page