Autoresponder problem

Discussion in 'General' started by lano, Jul 6, 2009.

  1. lano

    lano New Member

    For one of my client, I created mailbox and enabeled autoresponder with text somenthing like "test, we're outta here" for testing only.
    Now, tht text is sent to every person, who sent mail to that e-mail address, even if autoresponder is turned off. I checked in mysql base, and it is also off.
    My guess is, that ispc3 writes autoresponse message to another location.
    Where, and how to delete/disable it (make it work properly)?

    David
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The autoresponder is in the malbox directory of the user: /var/vmail/domain.tld/user/

    Which ISPConfig version do you use?
     
  3. lano

    lano New Member

    I found that directories, and I manualy deleted messages. I also delete domain, mailbox and re-created them.
    System error log shows:
    Code:
    Error  	Possible security violation when deleting the maildir:
    which seems to me ok, since I manualy deleted content.

    I also noticed records in ISPC Cron log:

    Code:
    mkdir: missing operand
    Try `mkdir --help' for more information.
    chown: missing operand after `vmail:vmail'
    Try `chown --help' for more information.
    Owner of /var/vmail/mailfilters and all subdirs is "vmail"

    Any sugestion?

    Version is 3.0.1.3
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, thats a problem that you deleted the mailbox manually instead pof delering it in ispconfig as ISPConfig is now not able to process any further changes. You will now have to delete the corresponding records in the mail_user and mail_domain database tables too.
     
  5. lano

    lano New Member

    I just deleted email mailbox and email domain and also checked in dbispconfig to be shure, that the records are deleted.
    Then I added domain and user mailbox, and when I try to add autoresponder, Ispconfig cron log shows
    Code:
    mkdir: missing operand
    Try `mkdir --help' for more information.
    chown: missing operand after `vmail:vmail'
    Try `chown --help' for more information.
    And also, there is no records in /var/vmail/mailfilters/domain.tld/mailbox
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    How exactly did you add them?
     
  7. lano

    lano New Member

    1. add client
    2. add email domain and assign it to client
    3. add mailbox

    Email is working properly.
     
  8. lano

    lano New Member

    I was monitoring tail -f /var/log/ispconfig/cron.log and noticed, that every time I add autoresponder message, I get error

    Code:
    mkdir: missing operand
    Try `mkdir --help' for more information.
    chown: missing operand after `vmail:vmail'
    Try `chown --help' for more information.
    That happens to all clients/mailboxes
    Any idea?
    System is Debian Lenny
     
  9. lano

    lano New Member

    I think I found the problem in the message.
    If I (or my customer) writes following message,
    Code:
    Obvescam vas, da sem na letnem dopustu od 7.7.09. do 21.7.09. LP
    then autoresponder works fine. But if customer signs with his name, then I get errors.
    Code:
    Obvescam vas, da sem na letnem dopustu od 7.7.09. do 21.7.09. LP
    Andrej Peternelj
    With any other text, responder works OK

    Edit:
    After testing different text, adding and removing signatures, etc., now sudenly everything started to work fine.

    Strange
     
  10. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi guys,

    I have the same problem:

    Possible security violation when deleting the maildir:

    Code:
    sh: repquota: not found
    mkdir: operando mancante
    Usare «mkdir --help» per ulteriori informazioni.
    chown: manca l'operando dopo "vmail:vmail"
    Usare «chown --help» per ulteriori informazioni.
    sh: repquota: not found
    
    I have not deleted any mailbox or mail domain manually. What happens?
     

Share This Page