Autoresponder not working?

Discussion in 'Installation/Configuration' started by cambo, May 10, 2007.

  1. lapena

    lapena New Member


    I've just found somethinginteresting. I added this command to the .procmailrc file :
    Si erverything is logged in this file. Here's the output after one test:

    /bin/sh: line 2: -oi: command not found
    /bin/sh: /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin: N
    o such file or directory
    procmail: Program failure (127) of "/home/admispconfig/ispconfig/tools/spamassas
    procmail: Rescue of unfiltered data succeeded
    /bin/sh: line 3: -oi: command not found

    So I think the problem is that the .autoresponder.rc isn't working well with spamassassin (No such file or directory).

    Moreover the error '-oi: command not found' seems to be due to the fact that the system can't lookup $SENDMAIL.

    How can I fix $SENDMAIL ? And how can I fix spamassassin error ?

    Kindest regards,
    Last edited: Jun 11, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    which sendmail
    Did you accidentally delete /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin?
  3. lapena

    lapena New Member

    i'm sure I didn't delete this folder, accidentally or not. i really take care before deleting anything.

    here's the output of the command which sendmail :

    and as said before, postfix is installed and here is exactly what is installed in /usr/sbin :

    ls -al /usr/sbin/sendmail*
    lrwxrwxrwx 1 root root 34 jun 4 12:48 /usr/sbin/sendmail -> /etc/alternatives/sendmail-command*
    -rwxr-xr-x 1 root root 23776 mar 8 17:19 /usr/sbin/sendmail.postfix*
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /etc/alternatives
  5. lapena

    lapena New Member

    lrwxrwxrwx 1 root root 26 jun 4 12:48 sendmail-command -> /usr/sbin/sendmail.postfix*
    lrwxrwxrwx 1 root root 26 jun 4 12:48 sendmail-command-in_libdir -> /usr/sbin/sendmail.postfix*
  6. lapena

    lapena New Member

    $SENDMAIL variable

    as said before, I saw in the log that the variable $SENDMAIL was unknown for procmail.
    so I've modified .autoresponder.rc to include this variable. I've added the line above:


    and it worked fine, until Ispconfig recreates the file, and this line didn't appear anymore.
    where should I write this variable so that it works anytime for any user ?

    kindest regards,
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You can put it in the procmailrc master template in /root/ispconfig/isp/conf/
  8. lapena

    lapena New Member

    thanks, I'll try this. I'm pretty sure it will work.

    and do you have any idea why i don't have this folder :

    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin ?

    (I'm sure i didn't deleted it - I even looked on history) and do you have any idea on how to recreate it ?

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a folder, it is a file.
  10. lapena

    lapena New Member

    you're right it's a file

    but the folder /home/admispconfig/ispconfig/tools/spamassassin/usr/bin doesn't exist. so the file doesn't exist too.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    If the folder and files does not exist, your ISPConfig is either not installed completely or spamassassin has been deleted.

    I recommend to download the latest ISPConfig version, unpack it and run the setup script. It will update your current installation and should "repair" the missing spamassassin too.
  12. cambo

    cambo New Member


    Yay! This solved my issue as well. :D :D :D

  13. linuxbastard

    linuxbastard New Member

    not sending mail out properly

    Hi till,

    I've been reading through the post.

    I've followed the solution and it seems to be working until i sent a mail from my gmail account. the autoresponder tried to respond but since it wasn't local mail it had to go through my smtp relay and it got rejected because it's being sent as [email protected]in instead of from [email protected]. here's the last maillog so you could get a better idea.

    Jul 22 21:13:35 srv-mkna01 postfix/smtp[13521]: C297B16DB9A: to=<[email protected]>, relay=smtp.*****[*****]:25, delay=3.9, delays=0.41/0.03/3/0.41, dsn=4.1.8, status=deferred (host smtp.****[****] said: 450 4.1.8 <[email protected]****>: Sender address rejected: Domain not found (in reply to MAIL FROM command))
    basically it's sending mail to non local addresses using a local user instead of the actual email address and it's being rejected by my smtp relay because the domain isn't fully qualified.

    any help would be appreciated.
    Last edited: Jul 22, 2008
  14. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    same issue in Mandriva, every version 2007, 2007.1 2008, 2008.1, i must modify every rc script template which send mail and there define variable
    if is default no mail is send.
  15. falko

    falko Super Moderator ISPConfig Developer

    Create an A record for server01.****.
  16. linuxbastard

    linuxbastard New Member


    Hi falko,

    thanks for the reply but i guess i need a little more info.

    Where do i create an A-record? On my local DNS server or on the one who handles my domains DNS records?

    Wouldn't it create a problem if one of the domains I'm hosting is the one I have in my local hosts file? like if my local server name is and one of my websites is
  17. linuxbastard

    linuxbastard New Member

    Everything seems to be working: Summary

    Apparently after I upgraded to ISPconfig 2.2.24, the master autoresponder.rc.master that I edited to add SENDMAIL=/usr/sbin/sendmail was overwritten but the autoresponder still worked even without the workaround. I don't know if it fixed the original issue but autoresponder is working without any modification.

    I added a DNS A-record at my DNS maintainer for my server,, and changed the hosts file and entries in for postfix and httpd.conf for the ispconfig web. I don't know if that's all I need to change (any ideas?). I also checked via ISPconfig control panel and made sure the DNS entries point to only for MX records.

    Everything seems to be working and I do get email responses even if I send it from a mail address outside of any hosts I have on server01.

    Thanks a lot for everything. Hope this helps someone else as well.

Share This Page