Autoresponder not working?

Discussion in 'Installation/Configuration' started by cambo, May 10, 2007.

  1. cambo

    cambo New Member

    Hi
    :eek: I give up - I have read every thread with autoresponder in it and can not find the answer.
    I have a user with Autoresponder ticked and a message in the box, however when you send an email to the user, there is no response.
    There are no forwards (so keep copy is not ticked either) I understand that autorespond script runs after these.
    I also understand only one response is sent per sender but there is no response at all.
    I have looked in all the config files to check settings as mentioned in other posts but can't find an answer.
    Here is user files to start:
    .autoresponder.rc
    Code:
    SHELL=/bin/sh    # for other shells, this might need adjustment
    EMAIL=`formail -zxTo:`
    
                  :0 Whc: vacation.lock
                   # Perform a quick check to see if the mail was addressed to us
                   #* $^To:.*\<$\LOGNAME\>
                   # Don't reply to daemons and mailinglists
                  * !^FROM_DAEMON
                   # Mail loops are evil
                  * !^X-Loop: ${EMAIL}
                  | formail -rD 8192 /var/www/web1/user/web1_kristina/.vacation.cache
    
                    :0 ehc         # if the name was not in the cache
                    | (formail -rI"From: kristina@industat.com.au" -I"Precedence: junk" \
                         -A"X-Loop: ${EMAIL}" ; \
                       cat /var/www/web1/user/web1_kristina/.vacation.msg \
                      ) | $SENDMAIL -oi -t
    
    
    .vacation.msg
    Code:
    Hi and thanks for emailing myself. I will be on annual leave from Monday the 7th of May returning to work on Monday 28th of May
    
    .vacation.cache shows about 20 email addresses.

    master.cf
    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # The script postfix-chroot.sh can be used to set up a Postfix chroot
    # environment on your Mandrivalinux System.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp	inet	n	-	y	-	-	smtpd
    #submission inet n       -       n       -       -       smtpd
    #  -o smtpd_enforce_tls=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps     inet  n       -       n       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #628      inet  n       -       n       -       -       qmqpd
    pickup	fifo	n	-	y	60	1	pickup
      -o content_filter=
      -o receive_override_options=
    cleanup	unix	n	-	y	-	0	cleanup
    qmgr	fifo	n	-	y	300	1	qmgr
    #qmgr     fifo  n       -       n       300     1       oqmgr
    tlsmgr	unix	-	-	y	1000?	1	tlsmgr
    rewrite	unix	-	-	y	-	-	trivial-rewrite
    bounce	unix	-	-	y	-	0	bounce
    defer	unix	-	-	y	-	0	bounce
    trace	unix	-	-	y	-	0	bounce
    verify	unix	-	-	y	-	1	verify
    flush	unix	n	-	y	1000?	0	flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp	unix	-	-	y	-	-	smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay	unix	-	-	y	-	-	smtp
    	-o fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq	unix	n	-	y	-	-	showq
    error	unix	-	-	y	-	-	error
    discard	unix	-	-	y	-	-	discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp	unix	-	-	y	-	-	lmtp
    anvil	unix	-	-	y	-	1	anvil
    scache	unix	-	-	y	-	1	scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=nobody argv=/usr/bin/maildrop -d ${recipient}
    #
    # Cyrus. Please See the Postfix CYRUS_README file for details
    #
    # deliver interface (deprecated), to use this also use
    # postconf -e cyrus-deliver_destination_recipient_limit=1
    cyrus-deliver     unix  -       n       n       -       -       pipe
      user=cyrus argv=/usr/lib/cyrus-imapd/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # for default cyrus socket placement
    cyrus     unix  -       n       n       -       -       lmtp
      -o lmtp_cache_connection=yes
    #
    # if you configure cyrus socket in the chroot jail
    cyrus-chroot     unix  -       -       y       -       -       lmtp
      -o lmtp_cache_connection=yes
    #
    # for lmtp to cyrus via tcp
    cyrus-inet	unix	-	-	y	-	-	lmtp
      -o lmtp_cache_connection=yes
      -o lmtp_sasl_auth_enable=yes
      -o lmtp_sasl_password_maps=hash:/etc/postfix/cyrus_lmtp_sasl_pass
      -o lmtp_sasl_security_options=noanonymous
    #
    # UUCP. Unix to Unix CoPy
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    # These are not distributed with Mandrivalinux
    #
    #ifmail    unix  -       n       n       -       -       pipe
    #  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    #bsmtp     unix  -       n       n       -       -       pipe
    #  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
    
    ##### START OF CONTENT FILTER CUSTOMIZATIONS #####
    # Please see the Postfix FILTER_README for details.
    # These sample entries expect your content filter to
    # listen on port 10025 and to inject mail back into
    # postfix on port 10026.
    #
    # to enable such content filter run the command
    #    postconf -e content_filter=smtp-filter:127.0.0.1:10025
    #    postconf -e smtp-filter_destination_concurrency_limit=2
    # or
    #    postconf -e content_filter=lmtp-filter:127.0.0.1:10025
    #    postconf -e lmtp-filter_destination_concurrency_limit=2
    # and the command
    #    postconf -e receive_override_options=no_address_mappings
    #
    
    127.0.0.1:10026	inet	n	-	y	-	-	smtpd
      -o content_filter=
      -o smtpd_restriction_classes=
      -o smtpd_client_restrictions=permit_mynetworks,reject
      -o smtpd_helo_restrictions=
      -o smtpd_sender_restrictions=
      -o smtpd_delay_reject=no
      -o smtpd_recipient_restrictions=permit_mynetworks,reject
      -o mynetworks=127.0.0.0/8
      -o smtpd_authorized_xforward_hosts=127.0.0.0/8
      -o strict_rfc821_envelopes=yes
      -o smtpd_error_sleep_time=0
      -o smtpd_soft_error_limit=1001
      -o smtpd_hard_error_limit=1000
      -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    
    lmtp-filter	unix	-	-	y	-	-	lmtp
      -o lmtp_data_done_timeout=1200
      -o lmtp_send_xforward_command=yes
      -o lmtp_cache_connection=no
      -o max_use=20
    
    smtp-filter	unix	-	-	y	-	-	smtp
      -o smtp_data_done_timeout=1200
      -o smtp_send_xforward_command=yes
      -o max_use=20
    
    ##### END OF CONTENT FILTER CUSTOMIZATIONS #####
    
    
    Sample log entry for this user after autoresponder started.
    Code:
    May 10 04:36:21 mdserver postfix/local[9184]: 624F468A1E: to=<web1_kristina@mdserver.mydomain.com>, orig_to=<kristina@mydomain.com.au>, relay=local, delay=60, delays=15/0/0/46, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    
    I can't find any errors or warnings in the logs.

    Can someone give me a clue where to look??

    TIA
    Cambo
     
  2. till

    till Super Moderator

    Is the email address that shall receive the autoresponder message in the .vacation.cache? If yes, remove it from there. The .vacation.cache is used to prevent sending of a utoresponder message multiple times to the same user. So if you test the autoresponder, you will get the message only once.
     
  3. cambo

    cambo New Member

    Hi Till
    OK, that's interesting. I wasn't sure of the function of .vacation.cache. The email addresses are in the cache but an autoresponce was never received. Not even once. I will clear the cache and try again.
    If there is not even the first autoresponce sent and the email address is in the cache again, what should I be looking for?
    Many thanks
    Cambo
     
  4. till

    till Super Moderator

    Please have a look at your mail log and post all entries that where addded when the mail is received and the autoresponder is sent.
     
  5. cambo

    cambo New Member

    Hi Till
    I checked with the local users who had sent an email to the user and none had received an autoresponce.
    I cleared the log and sent again. Same thing - no responce.
    I checked the next 5 minutes of log after the mail arrived and there is no sent msg in the log.
    It should respond straight away, shouldn't it?
    I also checked the errors and warnings logs and they are empty.
    I checked the mail queue and there is nothing in there.
    The email was delivered to the users inbox.

    (I also tried the autoresponder with a different user and same thing)

    Here is the relevant extract from /var/log/mail/info:
     
  6. falko

    falko Super Moderator

    Can you check again that the autoresponder is enabled in the user's .procmailrc file, and that the email address that is supposed to receive the autoresponder is not listed in .vacation.cache?
     
  7. cambo

    cambo New Member

    Hi Falko
    Here is the users procmail.rc
    I have cleared the vacation.cache twice.
    I am wondering if there is something wrong in another (related) area??
    Like, can I check that the ISPConfig autoresponder script is in the right place or is configured properly?
    Or is autoresponder just a function of procmail or postfix?
    Could it be my SMTP setup.
    I have done a vanilla Mandriva 2006 perfect install on this server.
    Thanks
    Cambo

    Code:
    ## MAILDIR=$HOME/Maildir/
    ## DEFAULT=$MAILDIR
    ## ORGMAIL=$MAILDIR
    
    INCLUDERC=/var/www/web1/user/web1_kristina/.mailsize.rc
    ## INCLUDERC=/var/www/web1/user/web1_kristina/.quota.rc
    INCLUDERC=/var/www/web1/user/web1_kristina/.antivirus.rc
    ## INCLUDERC=/var/www/web1/user/web1_kristina/.local-rules.rc
    ## INCLUDERC=/var/www/web1/user/web1_kristina/.html-trap.rc
    INCLUDERC=/var/www/web1/user/web1_kristina/.spamassassin.rc
    INCLUDERC=/var/www/web1/user/web1_kristina/.autoresponder.rc
    
     
  8. falko

    falko Super Moderator

    Can you post the contents of /var/www/web1/user/web1_kristina/.autoresponder.rc?
    What's the output of
    Code:
    updatedb
    locate .vacation.cache
    ?
     
  9. cambo

    cambo New Member

    More info.

    HI Falko
    Sorry for the delay but I only work on this system 2 days a week.

    contents of /var/www/web1/user/web1_kristina/.autoresponder.rc
    Code:
    SHELL=/bin/sh    # for other shells, this might need adjustment
    EMAIL=`formail -zxTo:`
    
                  :0 Whc: vacation.lock
                   # Perform a quick check to see if the mail was addressed to us
                   #* $^To:.*\<$\LOGNAME\>
                   # Don't reply to daemons and mailinglists
                  * !^FROM_DAEMON
                   # Mail loops are evil
                  * !^X-Loop: ${EMAIL}
                  | formail -rD 8192 /var/www/web1/user/web1_kristina/.vacation.cache
    
                    :0 ehc         # if the name was not in the cache
                    | (formail -rI"From: kristina@industat.com.au" -I"Precedence: junk" \
                         -A"X-Loop: ${EMAIL}" ; \
                       cat /var/www/web1/user/web1_kristina/.vacation.msg \
                      ) | $SENDMAIL -oi -t
    Result: updatedb
    locate .vacation.cache​

    Code:
    /var/www/web1/user/web1_ian/.vacation.cache
    /var/www/web1/user/web1_kristina/.vacation.cache
    /var/www/web1/user/web1_myles/.vacation.cache
    /var/www/web1/.vacation.cache 
    [I](above is link .vacation.cache -> /var/www/web1/user/web1_admin/.vacation.cache)[/I]
    
    Had the same problem with the other 2 users listed as well (ie. When Autoresponder is ticked, NO autoresponce was sent.)
     
  10. falko

    falko Super Moderator

    What's the output of
    Code:
    grep web1_kristina /etc/passwd
    ?
     
  11. cambo

    cambo New Member

    grep web1_kristina /etc/passwd
    Code:
    web1_kristina:x:10011:10001:Kristina:/var/www/web1/user/web1_kristina:/bin/false
     
  12. falko

    falko Super Moderator

    Is the email address that should receive the autoresponder message already listed in /var/www/web1/user/web1_kristina/.vacation.cache?
     
  13. cambo

    cambo New Member

    No. I have emptied the cache 3 times and tried again. The email address is in the cache after I send one, but there is no reply at all. I can't find anything in the logs where it has even tried to send a response.
    Could it be something related to, but not actually postfix, like DNS, or wrong permissions somewhere?
    Thanks for your help
    Cambo
     
  14. falko

    falko Super Moderator

    That's possible. Can you post a mail log excerpt from the time when an autoresponder message should get sent?
     
  15. lapena

    lapena New Member

    same problem

    Hello,

    I've installed a server with Mandriva Free 2007 Spring and ISPConfig.
    Autoresponder doesn't work. On ISPConfig I check "Autoresponder", I enter the message and click on "Save".
    The '.vacation.msg' contains the text, and the file '.vacation.cache' contains the email addresses who have sent a mail.
    Anyway I don't receive back any message (I've already cleared .vacation.cache several times).

    I'm still looking for fixing this problem, if anyone could help us it would be fine.

    Kindest regards,
    lapena
     
  16. falko

    falko Super Moderator

    What's in the mail log when an autoresponder should be sent?
    Also make sure that your server isn't blacklisted: http://www.mxtoolbox.com/blacklists.aspx
    Maybe it tries to send the autoresponder, but it isn't accepted by the receiving server because of some blacklists?
     
  17. lapena

    lapena New Member

    nothing appears in the log when a answer should be sent (I see the mail coming for the user and being delivered but no answer)
    the server isn't blacklisted, more over I've tested locally (sent a mail from the server with another user in the same domain)
     
  18. falko

    falko Super Moderator

    Can you check the .procmailrc file in the user's homedir whether the autoresponder is really enabled?
     
  19. lapena

    lapena New Member

    hello,

    here is the output of the .procmailrc file of the user (username is replaced with *):


    MAILDIR=$HOME/Maildir/
    DEFAULT=$MAILDIR
    ORGMAIL=$MAILDIR

    INCLUDERC=/var/www/web1/user/****/.mailsize.rc
    ## INCLUDERC=/var/www/web1/user/****/.quota.rc
    INCLUDERC=/var/www/web1/user/****/.antivirus.rc
    ## INCLUDERC=/var/www/web1/user/****/.local-rules.rc
    ## INCLUDERC=/var/www/web1/user/****/.html-trap.rc
    INCLUDERC=/var/www/web1/user/****/.spamassassin.rc
    INCLUDERC=/var/www/web1/user/****/.autoresponder.rc
     
  20. falko

    falko Super Moderator

    Looks ok. Then I have no idea why it's not working.
     

Share This Page