Autoresponder not working as expected

Discussion in 'Installation/Configuration' started by James A, Apr 3, 2014.

  1. James A

    James A Member HowtoForge Supporter

    Hi, the autoresponder has been causing me some issues so I'd like to confirm if I'm doing things wrong or if there are some bugs or features.

    The email subject doesn't appear to have any effect on the subject of the response email it always comes back with Auto Response: from ....

    The responder includes the main body of the text - surely this wouldn't be good if you receive the inevitable spam as you then re-spam.

    Clicking Enable the autoresponder without entering a date switches it on permanently - is this how it's supposed to work? Just got caught by this after importing an account where I assume it had had it selected but on import didn't bring in the time and date which switched on the autoresponder.

    Is there a template I can edit to change the behavior / appearance?

    Debian wheezy, ISPconfig, courier, postfix
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The template is in /usr/local/ispconfig/server/conf/ Store your modified template in /usr/local/ispconfig/server/conf-custom/
  3. James A

    James A Member HowtoForge Supporter

    Hi Till

    Thanks for your reply last week. I have managed to remove the original body text by adding -N option to mailbot.

    cc "| mailbot -N -t $RESPOND -d $RESPONDDB -c 'UTF-8' -D 1 \
    -A 'From: $RECIPIENT' -s 'Auto Response: from $RECIPIENT' \
    /usr/sbin/sendmail -t -f ''"

    Looking at correcting the subject, I'm somewhat unsure as I don't know where autoresponder.master is called from and what information we have at the time. ie if I wanted to do a lookup for the subject from the database I need to know the email address of the user, or something else unique.

    Otherwise I assume I would have to get a file writen containing the subject, similar to the .vacation.msg in the mailfilters.

    Final thing, for some reason when I copy autoresponder.master to conf-custom it doesn't override the original copy. I have tried dropping the .master extension but I am clearly missing something.

    Apologies for simple questions.
  4. bernie

    bernie New Member


    Hi James

    I have the same problem here as well. Since the update the file in the conf-custom folder doesn't overwrite the original file any more.

    Did you find a solution for that?

    Many thanks
  5. James A

    James A Member HowtoForge Supporter

    Hi Bernie

    Unfortunately not, but I haven't really been looking that hard.

    Just to clarify, is your issue with conf-custom with the latest ISPconfig update or with the version I am using ( If it's on the latter, it may have been fixed in .4 but I haven't upgraded yet so can't confirm that.

    Perhaps Till can comment.

  6. bernie

    bernie New Member

    Hi James

    Thanks for the reply. No, I'm using already the new Still the same problem.


Share This Page