Autoresponder installation problem cgi script won't run

Discussion in 'Installation/Configuration' started by MikeM, Sep 13, 2007.

  1. MikeM

    MikeM New Member

    I am trying to install the parabots autoresponder on my site. I uploaded the file autoinstall.cgi in ascii mode into cgi-bin/ar/ and set the permissions to 755 as per their instructions. When I run the file, nothing happens, just a blank page. I don't think it is running at all. I even tried their manual install, but it also wants to run autoinstall.cgi and can't do it. I see the folders are automatically set to 775. I tried setting it to 755, same result.

    I am using debian 4 and have cgi setup for the web site. I have run other cgi scripts before.

    Any ideas on why this file won't run?


    Mike Murphy
  2. catdude

    catdude ISPConfig Developer ISPConfig Developer

    What does it do from the command line?

    I don't know anything about patabots stuff (I try not to run code I have to pay for :))

    When you say you run the code, do you mean from the command line or through your web browser? If you make an ssh connection and run the code from the command line, what does it display?
  3. MikeM

    MikeM New Member

    Run from web.

    The script says to run the autoinstall.cgi from the web site. So I enter: and a blank page comes up, but the script does not activate or do anything.

    Don't know how to run it from the command line :(

    I'm pretty new at Linux stuff.
  4. catdude

    catdude ISPConfig Developer ISPConfig Developer

    Command line

    Ok, here's how.

    If ISPConfig is running on a machine that you have physical access to, just log in from the keyboard as root. If you don't have physical access, make an ssh connection to your ISPConfig machine fromwhatever machine you usually work from.

    Go to the directory where the cgi files are written. In my case, that's /var/www/<the domain name>/cgi-bin. I think you indicated that you installed if in cgi-bin/ar; so if you also used /var/www as the insatll base, you would do:
    cd /var/www/<your domain name>/cgi-bin/ar

    Verify that you're in the right place by doing:

    If you see the files you installed, then you're where you want to be.

    To execute the autoinstall.cgi file, do:

    This will not perform the installation for you, but if there is a problem like Perl installed in the wrong place, etc. this ought to display an error message that might help to point out what the problem is.

    One word of warning, though - logging in as root is dangerous! Think twice before executing any commands. Especially don't do any deletes (rm commands without checking carefully that you're entering the command you want.
  5. MikeM

    MikeM New Member

    OK, did that

    OK, I did that. I had to use web1 instead of my domain name, but same thing. I ran ./autoinstall.cgi and the only thing that happened was the command prompt came back right away. No errors or waiting.

  6. catdude

    catdude ISPConfig Developer ISPConfig Developer


    Oh. Well. That's - unexpected.

    If you do ls -Al in that directory, what does it show for file size on the autoinstall.cgi file?
  7. MikeM

    MikeM New Member

    Here it is

    It shows:

    total 136
    -rwxrwxrwx 1 web1_admin web1 131515 2007-09-13 14:44 autoinstall.cgi
  8. catdude

    catdude ISPConfig Developer ISPConfig Developer

    Unless someone else can come up with any additional suggestions, I think it might be time to give parabots a call.
  9. MikeM

    MikeM New Member

    OK, thanks for the help

    Yes, I think I'll do that. Thanks for the help and education :)


Share This Page