Autoresponder called from PHP not working

Discussion in 'General' started by TheRudy, Sep 4, 2006.

  1. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Hey

    Right, so i have an email set which is used in html forms. I also have Forward set so that submited form to the email it forwards it to my email. All good so far! Now the problem is that the sender aka the user who submited form from website with his email in the box, did NOT get auto respond from the email.

    If i send email from my client to this auto respond email i have set, i do get reply back. I don't get it if i use it in form on website..

    Any ideas why not?

    Using standart mail() from PHP..
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you set the from header in the email?
     
  3. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Yes ofcourse..
    I even used different email since once you get autorespond to an email, it will not send it anymore.. Need to change that also..
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post the PHP code where you generate the mails? I guess that the autoresponder messages are sent to the Apache user instead of the user who submits the form.
     
  5. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    That's correct falko, i checked logs eariler.. But anyway since i need to use 1 email with 3 different email respond templates, i'm going to simply use php to reply to the user.. problem solved ;)
     

Share This Page