Autoresonder doesn't work properly

Discussion in 'Installation/Configuration' started by domi-nik, Feb 3, 2010.

  1. domi-nik

    domi-nik New Member

    Hello

    Ispconfig 3.0.1.6 on Debian Lenny.
    Problem is that files .vacation.lst.gdbm and .vacation.lst.lock are not deleted.
    How to fix it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ive added the two files to the delete function in svn in the maildrop_plugin.inc.php file. The fix will be released as part of ispconig 3.0.2
     
  3. domi-nik

    domi-nik New Member

    Thanks.
    Can I safely update from svn or better wait for stable?

    I noticed one more thing, I can turn on autoresponder only for the primary domain. For the other domains, the user folder and files .vacation.msg and .autoresponder are not created.

    Sorry for my poor english.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    In ISPConfig, there is no such thing as a primary domain. All domains are equal.

    If the autoresponder files dont get created, take a look at the system log in the monitor and post the error message from there.
     
  5. vistree

    vistree Member

    also problem with autoresponder

    Hi Till,
    I have also problems with autoresponder AND mailfilter.
    If I activate autoresponder and/or mailfilter for a user mailbox, there are no files created in the users mail-dir (/var/vmail/domain/user/ )
    I can't get autoreponder to work.
    I checked all the logfiles in the monitor section of the current stable ispconfig3 - but can't find any corresponding messages. Which log would be the correct one? System log?
    I use ispconfig on a 64bit lenny.

    Hope you can help.
    Is there any way to set the autoresponder manually? E.g. by placing a .vacation in the users directory?

    Kind regards

    Kai
     
  6. domi-nik

    domi-nik New Member

    There are no entries in the logs. Autoresponder files are created only for one domain, that which was entered as the first after the installation of ISPConfig.
     
  7. vistree

    vistree Member

    Hi Domi-nik,
    what is the first domain for you? The first created maildomain or the first created site?

    Thank you for information

    vistree
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. domi-nik

    domi-nik New Member

    First domain -> the domain of my ISPConfig server.

    Here is the log after enabling autoresponder (to be read from the bottom):

    Debug No Updated records found, starting only the core.
    Debug Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    Debug Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    Debug Processed datalog_id 1014
    Debug Call function 'update' in plugin 'maildrop_plugin' raised by event 'mail_user_update'.
    Debug Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.
    Debug Found 1 changes, starting update process.
     
  10. vistree

    vistree Member

    Hi,
    If I set an autoresponder to one mailbox, I receive the following log-entries:

    Code:
    08.02.2010-09:27 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    08.02.2010-09:27 - DEBUG - Found 2 changes, starting update process.
    08.02.2010-09:27 - DEBUG - Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.
    08.02.2010-09:27 - DEBUG - Call function 'update' in plugin 'maildrop_plugin' raised by event 'mail_user_update'.
    08.02.2010-09:27 - DEBUG - Processed datalog_id 1241
    08.02.2010-09:27 - DEBUG - Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.
    08.02.2010-09:27 - DEBUG - Call function 'update' in plugin 'maildrop_plugin' raised by event 'mail_user_update'.
    08.02.2010-09:27 - DEBUG - Processed datalog_id 1242
    08.02.2010-09:27 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    08.02.2010-09:28 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    08.02.2010-09:28 - DEBUG - No Updated records found, starting only the core.
    08.02.2010-09:28 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    
    But still, in the folder of the user, there is no .autoresponder

    Any idea?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post screenshot of the autoresponder form.
     
  12. vistree

    vistree Member

    Hi Till,
    here are screenshots of one mailbox (attachement). I "removed" the email-address of the user!
     

    Attached Files:

  13. domi-nik

    domi-nik New Member

    Autoresponder form, Polish langauage.
     

    Attached Files:

  14. till

    till Super Moderator Staff Member ISPConfig Developer

    @vistreee: please post the output of:

    ls -la /var/vmail/mailfilters/domain.com/user/

    where domain.com is the domain name of the mailbox you posted the screenhsots from and user is the part in front of the @ of this mailbox.

    @domi-nik: you dont have a utoresponder enabled for this mailbix, so no autoresponse can be sent.
     
  15. vistree

    vistree Member

    Hi Till,
    Output is empty

    (domain.de and myuser are replacements for the mailbox-user I posted before)

    Kind regards

    vistree
     
  16. vistree

    vistree Member

    As an update:
    I created an mailbox for the domain with the id = 1 (mysql-table "web_domain").
    Here I can create autoresponder correctly and I find the 2 files in the corresponding /var/vmail/mailfilters/domain1.de/user

    Code:
    .autoresponder
    .vacation.msg
    So the effect seems to be exactly the same as for domi-nik

    Kind regards

    vistree
     
  17. vistree

    vistree Member

    Hmm, I created a mailfilter for an other user of the "problematic" domain, and afterwards also the autoresponder files were in the mailfilter folder.
    This trick does not work for the problematic user.
    So it seems to be a user-problem in this case.

    Is this helpful?
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Please disable the autoresponder checkbox for the non working user and click on save. Go back to the user and enable it again and click on save. Then go to the monitor and check the jobqueue until the changes have been processed (the jobs are not listed there anymore) and then check again on the shell if the autorespnder file has been created now.
     
  19. vistree

    vistree Member

    Hi Till,
    so I did.
    But there is no change in behaviour.

    Interesting is, that I tried to start the autoresponder for a totally different user, who never before activated the autoresponder.

    Using the message "testing" it worked.
    Afterwards I tried to change the messagetext to the one of the problematic user:

    Code:
    Sehr geehrte Damen und Herren,
     
    vom 01.01.2010 bis 01.03.2010 bin ich nicht erreichbar.
    In dringenden Fällen wenden Sie sich bitte an mein Büro (Tel.: 0000 - 000 000 00, [email protected]). 
    
    Erfahrungsgemäß wird in diesem Zeitraum mein Postfach überfüllt sein. Sollten Sie nach dem 5. März noch Interesse an einer persönlichen Antwort haben, senden sie mir ihr E-mail bitte erneut.  
    
    Mit freundlichen Grüßen
    Mein Name
    ---------------------------------------------------------
    Firma Firma
    Inhaberin: Der Inhaber
    Diestraße 6554
    77777 Teststadt
     
    Tel. (+49) 00000-000 000-00
    Fax (+49) 00000-000 559-00
    [email protected]
    www.domainname.de
    
    Neu: "Bei uns gibt es was neues - immer schön weiterlesen" Verlag, 99.95 €
    
    I inserted this text in the autoresponder field and clicked save. Now, nothing more is working for this user, too! The .vacation.msg still contains "testing".

    If I try to disable the autoresponder, the ispconfig log is fine, but the two autoresponder-files still exist in the users mailfiter-folder. Isn't this weird?
     
  20. vistree

    vistree Member

    OK, some more updates:

    I managed to "reset" the problematic user in the following way:
    * deleting all text from autoresponder message
    * disabling autoresponder
    --> Save

    Waiting until ispconfig-jobs are run.

    Going back to the autoresponder tab:
    * putting "test" in the message field
    * enabling autoresponder
    --> Save

    After job has run, I have all needed files in the users mailfilter folder.

    So, maybe the original message was to long, or there are some characters inside, which breacks the "update" procedure for the field??
     

Share This Page