autorepair filesystem on boot

Discussion in 'Installation/Configuration' started by cotthemh, May 20, 2008.

  1. cotthemh

    cotthemh New Member

    i use Fedora core 6, i have a very stable system which has an uptime usually of serveral months, which is very nice. The only times the system goes down is after power failures. Unfortunately it does not restart automatically because due to the power failure it requires a filesystem check (fsck). the system simply stops the boot because my main filesystem gets corrupt due to the powerfailure.

    this is my fstab :
    more /etc/fstab
    /dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0

    during boot the system wants a fsck -y in order to repair the filesystem. this howerver requires manual intervention on the console. This means i need to access the server physically to repair this.

    so my question :

    is there any way i can avoid this situation, and/or is there a way to automatically repair the filesystem during boot, rather than having to do it manually.

    many thanks for you're comments on this matter !

    best regards,

  2. falko

    falko Super Moderator ISPConfig Developer

  3. cotthemh

    cotthemh New Member

    if i look at my fstab and the definition which i found :

    the sixth field: fs_passno
    This field is used by fsck to determine which filesystems need to be checked when you reboot the system. According to the man page, the root file system should always be set to a 1 for this field and all other file systems can be set to 2. The fsck utility will check filesystems on different drives in parallel. If you leave this option off, it will be assumed to be a zero and fsck will not check the filesystem.

    in my case the root filesystem has option, which is what it should be and all others are set appropriately too. I don't think i can set this value to 2 for the root filesystem.

    i hope somebody can help me further with this, many thanks in advance !!
  4. falko

    falko Super Moderator ISPConfig Developer

    /dev/VolGroup00/LogVol00 / ext3 defaults,usrquota,grpquota 1 [B][COLOR="Red"]0[/COLOR][/B]
    in /etc/fstab.

Share This Page