Automate user signup.

Discussion in 'Tips/Tricks/Mods' started by Tommahawk, Aug 15, 2007.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    ispconfig_kunde.lib.php isnt needed anymore, first change the path to soap, eliminate the /web keep the signup.php in the same folder. second have you tried the test script? try it and see if it gives you any feed back. and is your error log giving anything of value?
  2. EWNOC

    EWNOC New Member

    where is the test script ? and what error log do you need to see I am still a linux noob
  3. EWNOC

    EWNOC New Member

    I gott it working to everyone make sure you do not use any speacial charecters in the remoting username **OR** password it will fail it!!!!!

    Thanks for all the support
  4. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Just a follow up, if you go to your web folder, where you have the autosignup, go to the web root, log, and open your error log. It gives you most errors, and leads you to solutions.
  5. rvarkevisser

    rvarkevisser New Member

    What's wrong?

    Oke... I've installed the remote framework on a clean install of debian Etch with ISPConfig + PHP5.2 with xml enabled. I created the remote user and uploaded the script, after editing it and changing the server/username/password.

    I tried http and https as the server URL. Also the soap1.lib.php didn't work and I got the error code:
    Fatal error: Cannot redeclare class soapclient in /var/www/web1/web/reseller/soap1.lib.php on line 4101

    I got another version, which didn't gave me this problem, but gave me the problem beneith after pressing Submit in the webform.

    Warning: SoapClient::SoapClient( [function.SoapClient-SoapClient]: failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error in /var/www/web1/web/reseller/reseller.php on line 120

    Warning: SoapClient::SoapClient() [function.SoapClient-SoapClient]: I/O warning : failed to load external entity "" in /var/www/web1/web/reseller/reseller.php on line 120

    Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from '' in /var/www/web1/web/reseller/reseller.php:120 Stack trace: #0 /var/www/web1/web/reseller/reseller.php(120): SoapClient->SoapClient('https://192.168...') #1 {main} thrown in /var/www/web1/web/reseller/reseller.php on line 120
    Last edited: Apr 11, 2008
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. rvarkevisser

    rvarkevisser New Member

    found the problem

    Till, I installed the latest framework 2 times.

    Oke found the solution for the second problem.
    In the reseller.php I renamed soapclient to soap_client.
    Now I get the message:

    registration is complete please login and created your email address and ftp login. When you login, click your website name, and you will find this under users and email.

    But nothing is changed. No user is added in the reseller list and no error is created. hmm...
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    And you installed the latest framework (the beta 4) and not the one linked on the page?
  9. rvarkevisser

    rvarkevisser New Member



    Are you gonna tell me a secret now about Beta4 and where I can download it?

    So no, I used the version 3 on the

    Last edited: Apr 11, 2008
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please read this thread, I posted the information above.
  11. rvarkevisser

    rvarkevisser New Member

    Acces Denied

    rvarkevisser, you do not have permission to access this page.

    To bad... Beta 4 is not for me, i think.
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try again, I changed the forum permissions to enable downloads from the dev forum for all users..
  13. rvarkevisser

    rvarkevisser New Member


    That worked. Thanks Till.
  14. rvarkevisser

    rvarkevisser New Member

    same problem

    I don't get it. I still have the same problem.

    registration is complete please login and created your email address and ftp login.

    But nothing is added in the reseller folder.
  15. bswinnerton

    bswinnerton New Member

    same problem here.
  16. rvarkevisser

    rvarkevisser New Member


    Here is what I did. I installed a clean Debian Etch with apache2, mysql, etc.
    I unpacked ISPconfig and changed the PHP installation in the file compile_aps/compile to the following.

    ./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --enable-mbstring=all --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php ${WITH_OPENSSL} ${WITH_MYSQL} ${WITH_ZLIB_DIR} --without-pear || error "Could not configure PHP"

    I downloaded the Beta 4 version and installed it in ISPConfig.
    I created an Remote User in ISPConfig and created a website with php (not safe mode) and ftp enabled. I checked the /remote/index.php to see if the Remote Framework was correctly installed.
    I then uploaded the scripts reseller.php and soap1.lib.php and renamed soapclient to soap_client in reseller.php. I changed teh settings in reseller.php to "https://<ip>:81/remote/index.php".
    But the soap1.lib.php included in the zip file is somewhat defect. I get the error "Cannot redeclare class soapclient .... line-number 4101"
    I uploaded my downloaded version of soap1.lib.php (which is 9kb bigger) and the error disappears.

    After that I get a nice message that my account has been created, but nothing else happens. Who can give me some tips where to start looking, because I cannot think of anything else.
    Last edited: Apr 11, 2008
  17. rvarkevisser

    rvarkevisser New Member

    oke UPDATE

    I used the script autosignup.php which can be downloaded here:
    from Tommahawk.

    I changed the remote user ip address from localhost to the network ip address and... I got myself a new client and website, but not a reseller..... YET!

    I keep trying. reseller.php definately doesn't work.... it's trash to me. sorry grandpa.
  18. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    check the names of soapclient, if you changed them in the soap.lib.php that may be the issue, the reseller script works, but you do have to edit the names, I was using it on fedora 6 and it worked fine without changing, but I had to change the naming of soapclient on debian. What distro are you using?
  19. rvarkevisser

    rvarkevisser New Member



    I use Debian Etch 4.0. You say change the name soapclient in soap.lib.php, but if I do a search on "soapclient" nothing is found. Can you explain what you mean?

    I did change the name soapclient in reseller.php to soap_client and that worked and I see in my version of soap.lib.php that soapclient is also renamed to soap_client. That's why my version is 9kb bigger than the version in your zip file.

    Last edited: Apr 11, 2008
  20. rvarkevisser

    rvarkevisser New Member

    It works!

    Oke... it works... I didn't see the soapclient in one instance and after I changed it, it worked great. Thanks GP.

    For this to work, change soapclient to "soap_client" in reseller.php AND in soap1.lib.php.
    Use the public/network ip for the remote user
    Use https in the server settings of reseller.php when using a ssl.

    Thanks Till and GP (sorry for the mistake GP)

Share This Page