Automate user signup.

Discussion in 'Tips/Tricks/Mods' started by Tommahawk, Aug 15, 2007.

  1. krakoukas

    krakoukas New Member

    I am going to work on it next week too... I'll post my results
    But it seems that it is not possible to ceate a web just after creating a client as the ispconfig batch process is not made.

    I am thinking about creating client first, then send a confirmation email where user have to log to a form that creates his web account. This way ispconfig will have time to create everything...
     
  2. till

    till Super Moderator

    The ISPConfig remoting framework allows it to create a website directly after you created a client. You should have a look at the examples in the remoting framework on the ISPConfog.org downloads page.
     
  3. krakoukas

    krakoukas New Member

    I have installed ISPConfig-2.2.14
    Then Remoting as seen in forum:

    Then I am using php source from example.
    I had to rename $soapclient in $soap_client in soap.lib.php as it generates a conflict with builtin php soap...

    Client is created but not web, and I have errors like:
    Do you see what could be wrong?
     
  4. krakoukas

    krakoukas New Member

    I think that the problem is about ISPconfig release 2.2.14
    I tried the same autosignup on a server running ISPConfig-2.3.1-dev.tar.gz and everything is fine...

    What could be the problem with my last install?
    Maybe I should install ISPConfig 2.2.17 (remoting is OK on it?)
     
    Last edited: Oct 2, 2007
  5. till

    till Super Moderator

    You are using really old versions. First, you should update to the latest ISPConfig version and the latest remoting framework. The Ioncube loader is not needed anymore for a long time.

    The errors you reported above are notices and not errors and they are dispaled beccause you enabled notices to be displayed in your php.ini. They do not mean that something went wrong.
     
  6. krakoukas

    krakoukas New Member

    You are right, but as I patched config.lib.php in order to add webdav support to web accounts, I am not migrating so often...

    Just a question: In last stable release 2.2.17, should i modify compile options (vi compile_aps/compile) in order to enable remoting?
    I am using Ubuntu 6.06, should I use the perfect Howto or any other installation directives?

    Thanks
     
  7. Tommahawk

    Tommahawk New Member

    From memory. I had to edit some core files to get it to work. It has to do with the procedure not creating a sys user in the database and therefore not being able to create a website. Test the script by creating a dummy user. You should have a new entries in the mysql database for kunde, sys_user & web. More on the issue....

    http://www.howtoforge.com/forums/showthread.php?t=14522

    Paypal IPN is almost finished and I will release it soon.
     
  8. krakoukas

    krakoukas New Member

    I have upgraded to 2.2.17 today. I couldn't succeed in making remoting work on it yet... I just change compile options, and installed remoting plugin + admin user.
    Do I lack something?

    Tommahawk, I also need Paypal IPN, and will work on it soon. Maybe we could share our effort on it?
     
  9. krakoukas

    krakoukas New Member

    I have now installed again 2.2.17.
    In order to use remoting, I have changed the compile options:
    I've added the remoting plugin through ispconfig web interface and added admin user/password with full rights (no IP specified)

    I removed the previously created ioncube folder (as it is not needed anymore) in /home/admispconfig/ispconfig/web
    Before removing it, I had soap catch "Error no data present after HTTP headers" but my client was created. I don't know for the others because of die quitting the script...

    Then I activated php log and when I use autosignup.php I have this error:
    I saw this thread talking about this error http://www.howtoforge.com/forums/showthread.php?t=15623&highlight=ispconfig_soap.obj.php

    But I feel lost...
    What should I do? Patch ispconfig_soap.obj.php? Install ispconfig from scratch again? Please give me an advice...
     
    Last edited: Oct 3, 2007
  10. krakoukas

    krakoukas New Member

    New installation (2.2.17), still the same problem...
    Only Client is created and
    if($err = $soap_client->getError()) die("Error client_add: ".$err);
    returns: Error client_add: HTTP Error: no data present after HTTP headers.

    Can someone help me or should I use development version of ISPconfig to be able to use remoting?
     
  11. till

    till Super Moderator

  12. krakoukas

    krakoukas New Member

    It should have curl compiled in as my client php script runs on my server (Version: 2.3.1) and already uses self remoting on it.
    I am just changing the server URL to reach my new 2.2.17 server...

    And the thread you mentionned shows the same problem as mine, but no real solutions...

    Don't you think it could be a problem with ispconfig_soap.obj.php ?
     
  13. till

    till Super Moderator

    I dont think so. This file contains the nusoap library which is widely used and not modified for ISPconfig.
     
  14. krakoukas

    krakoukas New Member

    But there is a problem... Could it be in the soap lib included with remoting test package?
    In order to use it, I had to rename "soapclient" into "soap_client" because of a conflict with included php soap lib?
     
  15. till

    till Super Moderator

    You can try to use the soap library that comes with your PHP instead of the soap library that is used in the examples. You can use any soap library with the ISPConfig server. Or you disable the soap extension in your php installation.
     
  16. krakoukas

    krakoukas New Member

    Still not running :(
    I even tried the latest dev release 2.3.3. And the same problem appears.
    So I tried to use Soap lib that comes with PHP:
    I have this error during soapclient creation:

    I don't understand what is happening...
    May be I could ask you to make the installation for me (on ubuntu 6.06)?
    If you have time to do it, I could pay for your offer "ISPConfig Remote Installation Support"...
     
  17. grandpagenocide

    grandpagenocide ISPConfig Developer

    krakoukas--
    Im having the exact same problem, It is creating the client just fine but not the web or ftp. Please let me know if you find the answer to this issue. And im talking to a couple people who are trying to help me get it running so if i get any posative results ill post it
     
  18. Tommahawk

    Tommahawk New Member

    I have added the edited ispconfig_kunde.lib.php file to the ISPConfig Auto-Signup Script @ http://www.5s7.com/scripts.php

    /home/admispconfig/ispconfig/lib/classes/ispconfig_kunde.lib.php

    No warrenties. Use at your own risk.

    The remoting issue goes something like this: when adding a new kunde, remoting does not create a sys_user which causes adding a website to fail. To check you need to setup a default install run my autosignup script and see if you can get use remoting to create db entries in kunde, sys_user and isp_isp_web without using the edited ispconfig_kunde.lib.php all three database entries and relative nodes need to be statisfied for a customer to signup and immediately register/login and upload their site. Paypal/ecommerce verfication will return true and the script will set things up.
     
    Last edited: Oct 11, 2007
  19. grandpagenocide

    grandpagenocide ISPConfig Developer

    Tommahawk, Thanks alot it works perfect
     
  20. krakoukas

    krakoukas New Member

    No luck for me (even with your patched ispconfig_kunde.lib.php) ;(
    Maybe it's because of my downgrade from 2.3.3 dev to 2.2.17
    Or beacuse of too many dirty ispconfig install/remove?

    Next monday, I will try to make a clean install following: http://www.howtoforge.com/perfect_setup_ubuntu_6.06 on a newly installed system

    Tommahawk, I would like to ask you how do you manage soapclient calls?
    From "soap.lib.php" or builtin PHP soap?

    As I don't know how to remove builtin PHP soap, I renamed from the client script and "soap.lib.php" "soapclient" into "soap_client". Could you or anybody explains me waht is the best way to use soap?

    Many thanks, I hope that my fresh install will work...

    PS: grandpagenocide did you used the patched kunde lib?
     

Share This Page