Autoinstaller arm64 error

Discussion in 'Installation/Configuration' started by brainsys, Feb 8, 2022.

  1. brainsys

    brainsys Member

    I'm getting: [ERROR] Exception occured: ISPConfigOSException -> Installing packages failed. (/ispconfig.ai.php:15)

    It failed after attempting to install Installing packages:

    software-properties-common, dnsutils, resolvconf, clamav, clamav-daemon, clamav-docs, zip, unzip, bzip2, xz-utils, lzip, rar, arj, nomarch, lzop, cabextract, apt-listchanges, libnet-ldap-perl, libauthen-sasl-perl, daemon, libio-string-perl, libio-socket-ssl-perl, libnet-ident-perl, libn et-dns-perl, libdbd-mysql-perl, bind9, spamassassin, rspamd, redis-server, postgrey, p7zip, p7zip-full, unrar-free, lrzip

    I suspect this is because rar is not available on Debian 11/arm64. I had that problem with a manual installation on Debian 10. I also had an issue with rspamd but there is a directive to not tinstall. Hence I'm looking for a way to modify the script to not install rar or anything else that may cause a hiccup.

    I've had a look in the /tmp/ispconfig-ai directory but can't find the apt install commands. What do you suggest?
     
    Last edited: Feb 8, 2022
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Check in this file: class.ISPConfigDebianOS.inc.php
     
  3. brainsys

    brainsys Member

    Thank you. Found it in a /tmp subdirectory. Sorry to be naive but how can I safely restart the autoinstaller that will not re-download and overwrite the amended file?
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share the content of /etc/apt/sources.list ?
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    The best thing to do is reinstall your server.
     
  6. brainsys

    brainsys Member

    Code:
    # cat /etc/apt/sources.list
    deb http://deb.debian.org/debian bullseye main contrib non-free
    deb http://security.debian.org/debian-security bullseye-security main contrib non-free
    deb http://deb.debian.org/debian bullseye-updates main contrib non-free
    # Uncomment deb-src lines below then 'apt-get update' to enable 'apt-get source'
    #deb-src http://deb.debian.org/debian bullseye main contrib non-free
    #deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free
    #deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free
    
    Just to add I removed the goaccess & rspamd repositories added in sources.list.d as these don't support arm64. However the apps are in the debian repositories
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't think that the installer will work on Arm64 systems, it is made for x86_64 (amd64) architecture, so as long as there are missing packages on ARM, then it won't work. What might be an option if we know which packages to exclude on arm64 servers, then we could extend the installer to either detect srm64 or adding a command-line option for such a mode.

    The installer has already a debug mode, which just write a more detailed log to see which commands fail on arm64.
     
  8. brainsys

    brainsys Member

    The autoinstaller works great on my amd64 servers. The issue is the autoinstaller is designed for amd64 architectures and never did work on arm64. Which is why some of us have been asking for a Debian 11 Perfect Tutorial. The Debian 10 version worked well on my Buster arm64 systems and any issues could be worked around easily without crashing stuff.

    I will see what I can salvage using the Debian 10 tutorial again. Having spent ages sorting the IPv6 networking I'm loathed to wipe the server and start that again.
     
  9. Rex

    Rex Member

    I'm having the same problem. If we force to use default arm64 source.list, would it work? By the way, where can I check each install command run?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    I'm not sure if all packages are available for arm64, e.g. unrar might be missing.

    They should be in the install log when you run the auto installer in debug mode. Or you take a look at the auto installer code directly:

    https://git.ispconfig.org/ispconfig/ispconfig-autoinstaller/-/tree/master
     
  11. cyclic

    cyclic New Member

    Test Install of "ISPConfig3 Single Server" on arm64
    Stock new pi4
    Fresh "2022-01-28-raspios-bullseye-arm64-lite"

    Using "Perfect Server Automated ISPConfig 3 Installation on Debian 10 - 11 and Ubuntu 20.04" instructions.
    I notice that second wget line has "sloping" pipe. Typo ?
    With real pipe get:

    [ERROR] Exception occured: ISPConfigOSException -> Installing packages failed. (/ispconfig.ai.php:15)

    Pre-tests apt search show unrar and unrar-free available in distribution
    but package rar has no installation candidate
    Does unrar include rar as well ?
    Have not found how to use automatic and NOT try to install rar to test
    Is there a way?

    All the other things seem to install ok
    but because auto installer bombs out I cannot move to the next hurdle.
     
  12. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  13. cyclic

    cyclic New Member

    I am using "Perfect Server Automated ISPConfig 3 Installation on Debian 10 - 11 and Ubuntu 20.04" instructions.
    In those instructions the first wget - -help goes OK (obviously).
    The second wget --which does the install fails with error message:
    [ERROR] Exception occured: ISPConfigOSException -> Installing packages failed. (/ispconfig.ai.php:15)
    This is not very informative so I went digging around found what it had tried to install.
    In the list there are ar & unrar.
    till has commented on unrar above but unrar is there and does install.
    On the other hand rar package is not found
    I do not know if rar is mission critical or included in unrar

    I am not using RaspOS which is retired.
    I am using pios64 which is to all intent and purposes Debian 11 bullseye (with pi hw extras addon).
    So this is really "just" a Debian 11 Bulleye install using the superduper auto install shell

    Should rar be removed from package list in the auto install ?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    rar is used by ISPConfig backup function, so it's required to have the full functionality in ISPConfig. So removing it is not an option, but as I mentioned earlier, we might add an installer Commandline option for arm64 systems which installs a system with reduced functionality and leaves out packages that are not available for arm64.
     
    Th0m likes this.
  15. cyclic

    cyclic New Member

    For information, relating to auto install with arm64:
    Another package not found in Debian 11 Bullseye arm64 is getmail4
    getmail is there though
     

Share This Page