Autoforward original sender's name disappear

Discussion in 'Tips/Tricks/Mods' started by stocek, May 28, 2014.

  1. stocek

    stocek New Member

    Hi

    I've set up a mail (info@mydomain.net) in ISPconfig which works fine, this mail sends a copy to a mailforwarder (fw@mydomain.net) also set up in ISP config

    the mailforwarder autosends to 3 different external mailaddress. Everything is ok, but there's no sender's name in the header altough it is set up in the original mailaddress.

    So some external mailservers drop my message.

    Can someone help me?


    my system is Debian/Postfix/Courier/ISPConfig 3.0.5.3

    here is a piece of log:

    grep 'external.hu' /var/log/mail.log
    May 27 09:13:05 bolka amavis[970]: (00970-16) Passed CLEAN, [127.0.0.1] [178.48.45.59] <> -> <someone@external.net>, Message-ID: <005201cf797b$17287760$45796620
    $@stocek.hu>, mail_id: dltAWPw8uR59, Hits: -2.333, size: 110469, queued_as: A6225101BA0, 225 ms
    May 27 09:13:05 bolka postfix/smtp[2201]: 7C0A3101B51: to=<someone@external.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.25, delays=0.02/0/0/0.23, dsn=2.0.0,
    status=sent (250 2.0.0 Ok, id=00970-16, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as A6225101BA0)
    May 27 09:13:06 bolka postfix/smtp[1246]: A6225101BA0: to=<someone@external.net>, relay=mail.external.net[000.00.100.90]:25, delay=0.44, delays=0.05/0/0.
    05/0.33, dsn=2.0.0, status=sent (250 OK id=1WpBZK-0005xx-1S)
    May 27 22:10:58 bolka postfix/smtp[12573]: 6D822101B6C: to=<someone@external.net>, orig_to=<fw@mydomain.net>, relay=mail.external.net[000.00.100.90]:25
    , delay=0.83, delays=0.01/0.03/0.07/0.72, dsn=2.0.0, status=sent (250 OK id=1WpNi6-0002xu-6p)
    45.59] <> -> <someone@external.net>, Message-ID: <005201cf797b$17287760$ 45796620$@stocek.hu>, mail_id: dltAWPw8uR59, Hits: -2.333, size: 110469, queued_ as: A6225101BA0, 225 ms
     

Share This Page