Auto-subdomain not working

Discussion in 'Installation/Configuration' started by juansa, Oct 22, 2014.

  1. juansa

    juansa New Member

    Hey people.
    When I create a site I set auto-subdomain to "www."
    However when I go to domain.com it doesn't take me to www.domain.com

    1. I've checked the /etc/apache2/sites-available/100-domain.com.vhost and which shows:
    <Directory /var/www/domain.com>
    ... </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/domain.com/web
    ServerName domain.com
    ServerAlias www.domain.com
    ServerAdmin webmaster@domain.com

    2. I've also checked that mod_rewrite is definetely working, since I'm running wordpres 4 in that domain and I'm using the permanent links option.

    3. .htaccess in /var/www/domain.com shows:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    So... Help!
     
  2. juansa

    juansa New Member

    MY BAD!

    Problem was the Wordpress settings when installed from the APS INSTALLER.
    In the General Settings menu it adds "domain.tld" which therefore redirects always removing the "www." prefix.

    You can close this if you wish, or leave it is you believe it will be useful for someone else.

    Thanks!
     

Share This Page