auto subdomain not working, 403 error. ispconfig 3

Discussion in 'Installation/Configuration' started by SeanT, Mar 6, 2009.

  1. SeanT

    SeanT New Member

    I'm having an issue with auto subdomains and subdomains in general. I created a client and added the site if I go to domain.tld it works fine, however if I go to www.domain.tld I get a 403 error. I tried removing the site and readding it and I'm still having the same issue. Any advice would be appreciated.

    I'm running ispconfig 3 and Ubuntu server 8.10
     
    Last edited: Mar 6, 2009
  2. SeanT

    SeanT New Member

    Anyone have any thoughts? I really need to get this working... I tried removing the website again and then going to domain.tld and it brought up the default apache site, however www.domain.tld brought up the 403 page... I'm really at a loss here...
     
  3. robilaur

    robilaur New Member

    Log in to ISPconfig , then click on sites , then select the site and then select "Auto-subdomain" to www. and press save
     
  4. SeanT

    SeanT New Member

    Tried that, and *.

    Here is the config for the site

    <VirtualHost *:80>
    DocumentRoot /var/www/eviltomatomedia.com/web

    ServerName eviltomatomedia.com
    ServerAlias www.eviltomatomedia.com
    ServerAdmin webmaster@eviltomatomedia.com

    ErrorLog /var/log/ispconfig/httpd/eviltomatomedia.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/eviltomatomedia.com/web>
    Options FollowSymLinks
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    # cgi enabled
    ScriptAlias /cgi-bin/ /var/clients/client6/web8/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@eviltomatomedia.com"
    php_admin_value upload_tmp_dir /var/clients/client6/web8/tmp
    php_admin_value session.save_path /var/clients/client6/web8/tmp
    #php_admin_value open_basedir /var/clients/client6/web8:/usr/share/php5


    </VirtualHost>
     
  5. robilaur

    robilaur New Member

    Look`s fine to me.... do u have the domain in the DNS records?... and u have www there?
     
  6. SeanT

    SeanT New Member

    Yep, www is a CNAME to the domain, the dns is hosted on the same machine.

    I've restarted apache, I've even restarted the machine
     
  7. robilaur

    robilaur New Member

    R u hosting the domain entirely on your server? or u have it on other service from where u make your pointings?
     
  8. SeanT

    SeanT New Member

    it's all hosted on this one server.
     
  9. SeanT

    SeanT New Member

    I just created a subdomain for mail. and that works fine... for some reason www will not work regardless of if I have it set as an auto subdomain or I manually create it... it makes no sense
     
  10. robilaur

    robilaur New Member

    OK.... thats wired then.... try to make a A record of www.domain.tld pointing to your ip.
    My setup is like this :
    A domain.tld. 89.40.-.-
    A www 89.40.-.-
     
  11. SeanT

    SeanT New Member

    still no luck, and fyi mail. is also a cname record this is really starting to confuse the hell out of me lol
     
  12. robilaur

    robilaur New Member

    heck... I dont know.... install debian :)) it will work :)
     
  13. SeanT

    SeanT New Member

    well I just tried it on another ispconfig 3 server that I setup a couple days ago and haven't touched, added the client, the dns, and the website didn't do an auto subdomain I created it manually again it works fine for mail but fails for www I guess this must be an ubuntu related issue? Really sucks I now have to do a clean install just to get this working... oh well Thanks for the help.
     
  14. robilaur

    robilaur New Member

    well.... look on the forum....there is a script that installs everythig by the book automatikli... u only have to do the Os install and then run that script.
    Ok take care
     
  15. SeanT

    SeanT New Member

    Yep, I saw that and plan on using it =] Thanks again, hopefully I can get this done in an hour or two, sleep would be nice at some point...
     
  16. robilaur

    robilaur New Member

    Well ....if everithing goes without a problem u shoul have it up and running in 1:30 hours max
     
  17. SeanT

    SeanT New Member

    just finished installing debian lenny and working on installing ispconfig hopefully it doesn't shit the bed again.
     
  18. robilaur

    robilaur New Member

    PLease tell me if that install works great..
     
  19. PermaNoob

    PermaNoob New Member

    www should be an A (address) pointed to the ip, not CNAME, at least, that's what works for me.
     

Share This Page