Authentication problem

Discussion in 'Server Operation' started by SamTzu, Oct 24, 2007.

  1. SamTzu

    SamTzu Member HowtoForge Supporter

    I don't know what happend but suddenly no new users can login.
    Old users are fine.

    I'm using the VMWare ISPConfig image and when I look in /var/log/auth.log

    But when I login with old user it does not show any errors.


    Sam

    PS. I'm wondering if this has something to do with the other problem that come up with the "catch-all"
    I'm still getting wrong persons [email protected] mails.
    Details here.

    PPS. I tried to see if I could get it to work by deleting the domain and creating it a new.
    Unfortunatelly I get this when looking in the recycle-bin...
    The system is currently updating the configuration files.
    It has done that for 15min now. (It finally showed after a long time.)

    PPPS. It seems that there are also older users who can not login anymore.
     
    Last edited: Oct 24, 2007
  2. SamTzu

    SamTzu Member HowtoForge Supporter

    AARGGHhh

    No luck after reboot.

    Looks like removing the whole domain and redoing it fixed the problem. :eek:
    Also I could login after creating a new user.

    That can only be the final solution.

    Can someone figure out a more convenient solution?


    Sam
     
    Last edited: Oct 24, 2007
  3. SamTzu

    SamTzu Member HowtoForge Supporter

    OK. When I try to login with ssh as someone who has access problems I get this message in putty...

    Access denied
    Using keyboard-interactive authentication.

    I checked that the user has these options checked...

    Administrator:
    Shell Access:


    So..? Whats going on?

    I'm pretty sure that If I would delete the users domain and start from new it would work again. But I don't want to do that.


    Sam
     
  4. SamTzu

    SamTzu Member HowtoForge Supporter

    Oki.

    Looks like this could be self inflicted.

    I look at the users site folder and see this...
    -rwxrwxr-x 1 www-data web25 83 2007-10-24 04:00 .htpasswd

    On all the other users sites the owner is root not www-data.

    What could be the couse of this?


    Sam
     
  5. SamTzu

    SamTzu Member HowtoForge Supporter

    Changing the permissions back to root on the users / folder solved the problem.
    I wonder how the www-data had aquired the file permissions in the first place?

    Any ideas?


    Sam


    Loki mummy... I solved it all by my self.:D
     

Share This Page