Authentication Issue with pure-ftpd-mysql

Discussion in 'Installation/Configuration' started by msp20, Jan 23, 2022.

  1. msp20

    msp20 New Member

    Hello,
    I have 2 FTP users: 1 older one, and 1 new one that I just created.
    I'm using ispconfig 3.2.7.
    Ubuntu 18.04.6 LTS
    pure-ftpd v1.0.46 [privsep]
    mysql Ver 15.1 Distrib 10.1.48-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

    First of all, the server (pure-ftpd-mysql) is up and running, and user 1 can access it.
    User 1's passwort hash in dbispconfig/ftp_user starts with $1$.

    User 2 however cannot authenticate.
    User 2's password hash in dbispconfig/ftp_user starts with $6$rounds=5000$

    Code:
    Jan 23 13:13:11 server1 pure-ftpd: ([email protected]:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx) [INFO] New connection from 2001:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx
    
    Jan 23 13:13:16 server1 pure-ftpd: ([email protected]:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx) [WARNING] Authentication failed for user [ftp_xxxxxx_1]
    Jan 23 13:13:16 server1 pure-ftpd: ([email protected]:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx) [INFO] Logout.
    Does someone have an idea whats going on here?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to set a different password, might be that the password you are using has a special char which gots escaped in the wrong way, there are known problems with passwords that contain umlauts for mail accounts and the same issue might probably affect FTP users too.
     
  3. msp20

    msp20 New Member

    Unfortunately, this doesn't seem to solve the issue. I tried a simple alphanumeric password and two different clients (WinSCP and Explorer)
     
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Any unfinished job in ISPConfig UI? Anyway, I will normally create another user or delete and recreate user2 and retry.
     
  5. msp20

    msp20 New Member

    No unfinished jobs in ISPConfig queue. Deleting and re-creating the user has no effect.
     
  6. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Seems like something is broken somewhere and I would run a test on my server if that happened, but before that did you create another user that is not the same user?
     
  7. msp20

    msp20 New Member

    I created other ftp users (for different clients) for test purposes and they can log in. Their pw hashes start with $6$ as well, so on the contrary of my initial hunge, this does not seem to be the issue.
     
  8. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    So problems only happen to this one client only? Any settings you made different from others?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Does the directory of that FTP user exists on the shell and does he has access to it?
     

Share This Page