AUTHENTICATE PLAIN invalid

Discussion in 'Installation/Configuration' started by ferradeira, Dec 14, 2006.

  1. ferradeira

    ferradeira New Member

    I'm running ispconfig on a suse10 server. I have changed port 81 to 82 because of ipcop.
    I have installed squirrelmail, but when I try to login I allways get this error:
    Bad request: AUTHENTICATE PLAIN invalid

    I'm using sendmail and in the squirrelmail configuration is:
    IMAP Server : "the name of the server (/etc/hosts)"
    5. IMAP Port : 143
    6. Authentication type : plain
    7. Secure IMAP (TLS) : 0
    8. Server software : other
    9. Delimiter : detect

    Do I have to login with the complete email address or use the user name created by ispconfig (web2_username)?

    thanks

    ferradeira
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to use the username, not the email address. Did you follow the perfect setup guide to configure your server for ISPconfig?
     
  3. ferradeira

    ferradeira New Member

    I did not follow the perfect setup guide. I installed Suse and all the software needed for ISPconfig and follow the installations instructions.

    With the user name found in /etc/passwd i was not able to login, get the same error: Bad request: AUTHENTICATE PLAIN invalid

    The server is installed in a DMZ zone of the IPCop, with this IP address 192.168.3.201. I found this error in /var/log/mail:

    Dec 14 19:35:13 griseu6 imapd[24832]: AUTHENTICATE PLAIN invalid host=griseu6.logicworks.pt [192.168.3.201]
    Dec 14 19:35:13 griseu6 imapd[24832]: Command stream end of file, while reading line user=??? host=griseu6.logicworks.pt [192.168.3.201]

    Any ideas? Did I make anything wrong?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It looks like plain authentication is not enabled in your courier setup. Please have a look at the imap configuration file in /etc/courier/ if you can enable it there.
     
  5. ferradeira

    ferradeira New Member

    I don't have /etc/courier/ in my system.
    I have enabled imap in the /etc/services file:

    imap 143/tcp imap2 # Internet Message Access Protocol
    imap 143/udp imap2 # Internet Message Access Protocol

    pop3 110/tcp # Post Office Protocol - Version 3
    pop3 110/udp # Post Office Protocol - Version 3

    The port 143 enables plain text in imap.

    Any more ideas?
     
  6. ferradeira

    ferradeira New Member

    Another point is I'm accessing squirrelmail using https and port 82.
    Maybe this is not the problem!?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Which IMAP daemon do you have installed?
     
  8. ferradeira

    ferradeira New Member

    the package is imap-2004g_suse-16.2
     
  9. ferradeira

    ferradeira New Member

    should I install another imap package?
     
  10. falko

    falko Super Moderator ISPConfig Developer

    I suggest you install Courier, as shown on http://www.howtoforge.com/perfect_setup_suse_10.1_p5 :

    Code:
    yast -i courier-imap fam-server courier-authlib expect tcl
    Don't forget to enable Maildir under Management -> Server -> Settings -> Email in ISPConfig as Courier uses Maildir.
     
  11. ferradeira

    ferradeira New Member

    I cannot find courier-imap on my installations CDs. What I found is cyrus-imapd. Should I install this one?.
    My system is SuSE Linux Enterprise Server 10.
     
    Last edited: Dec 19, 2006
  12. falko

    falko Super Moderator ISPConfig Developer

    No, don't install Cyrus, it's not supported by ISPConfig. Please run
    Code:
    yast
    and search for courier packages. Do you find any?
     
  13. ferradeira

    ferradeira New Member

  14. till

    till Super Moderator Staff Member ISPConfig Developer

    I think thats a good idea. SuSE enterprise does come with a limited.
     
  15. ferradeira

    ferradeira New Member

    Ok, I have installed OpenSuse 10.2 following the instructions on http://www.howtoforge.com/perfect_setup_opensuse_10.2

    Then I install ISPConfig-2.2.9, with this message at the end:

    Connected successfully to MySQL server
    ls: cannot access /etc/apache2/vhosts.d/*.conf: No such file or directory
    ls: cannot access /etc/apache2/vhosts.d/*.conf: No such file or directory
    Restarting some services...
    which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    Shutting down mail service (Postfix) done
    Starting mail service (Postfix) done
    Shutting down mail service (Postfix) done
    Starting mail service (Postfix) done
    Shutting down ProFTPD Server: done
    Starting ProFTPD Server: done
    Shutting down ProFTPD Server: done
    Starting ProFTPD Server: done
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to

    Then I have changed port 81 to 82

    Now I cannot access using https and port 82. With IE6 i have a message that the page cannot be displayed and with FF2 I have a message telling that it cannot connect to an encrypted connection because the certified has an invalid signature.

    Any ideas?
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

  17. ferradeira

    ferradeira New Member

    GREAT
    Now it's working. I can create folders and upload files under web-ftp.
    Next step is install squirremail.

    Many Thanks
     

Share This Page