authdaemond: failed to connect to mysql serve

Discussion in 'General' started by Taleman, Jun 25, 2015.

  1. Taleman

    Taleman New Member HowtoForge Supporter

    (Debian Squeeze/Sid) ISPConfig 3.0.5.4p8

    After upgrading to p8 today, I get in /var/log/mail.err:

    Code:
    Jun 25 16:36:21 ispc3 authdaemond: failed to connect to mysql server (server=localhost, userid=ispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    Jun 25 16:36:21 ispc3 imapd: authentication error: Input/output error
    Jun 25 16:36:21 ispc3 authdaemond: failed to connect to mysql server (server=localhost, userid=ispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    Jun 25 16:36:21 ispc3 imapd: authentication error: Input/output error
    When upgrading, I did slave first and remembered to answer yes to "Reconfigure Permissions in master database?". I have only one slave. On master I answerd no.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to restart all courier services and mysql.
     
  3. Taleman

    Taleman New Member HowtoForge Supporter

    The errorr messages I posted are right after rebooting the server.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. nad did you restart the services incl. mysql after you rebootet the server? According to the error, mysql is not running. so it might be that it was not started after reboot.
     
  5. Taleman

    Taleman New Member HowtoForge Supporter

    There is something strange with starting services at boot. I noticed from /var/log/syslog that also mydns failed to start:

    Jun 25 16:36:16 ispc3 mydns[1320]: Error connecting to MySQL server at localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) (errno=2)

    I started the service by hand, and now it starts:
    Jun 25 18:03:51 ispc3 mydns[20161]: mydns 1.2.8.31 started Thu Jun 25 18:03:51 2015 (listening on 4 addresses)

    Are the startup scripts messed up, and no longer start services in the right order?
    I stopped Courier and started it again. Now looks like the errors did not appear. I have scripts to stop and starts all parts of Courier.
     
  6. Taleman

    Taleman New Member HowtoForge Supporter

    mysql was running, I checked with service mysql status
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats probably the case, mysql was started after the other services. But this has nothing to do with the p8 update as ISPConfig has no influence on start scripts or boot oder of system services.
     

Share This Page