Attempting to use additional php version, Centos7, ispconfig3.0.5.4p9

Discussion in 'ISPConfig 3 Priority Support' started by ronee, Jul 2, 2016.

  1. ronee

    ronee Member HowtoForge Supporter

    Hello,
    We have added php5.6 using the remi repository to a system running centos7, all seems to be in order with that and the additional php version was added in the system area, however the additional php version drop down box does not show up in existing website entries. Starting a new site entry does provide a "PHP Version" drop down box however it lists only "Default".

    We've restarted apache and so forth. Would be interested in any suggestions on making php5.6 selectively available based on the way we've installed it. As a note php5.6 was added after ispconfig was already installed, not sure if that makes a difference.

    The php 5.6 fastcgi settings we have are:
    path to binary: /opt/remi/php56/root/usr/bin/php-cgi
    path to php.ini: /opt/remi/php56/root/etc
    the php 5.6 php-fpm settings we have are:
    path to php-fpm init script: php56-php-fpm
    path to php.ini directory: /opt/remi/php56/root/etc
    path to php-fpm pool directory: /opt/remi/php56/root/etc/php-fpm.d

    Thanks
     
  2. ronee

    ronee Member HowtoForge Supporter

    Nevermind, issue resolved - once fastcgi or php-fpm is selected, the php version drop down shows up.
     
  3. ronee

    ronee Member HowtoForge Supporter

    All right so now we have a slightly different issue hoping we can resolve. Everything works fine using Centos7, but on Centos6 and the remi php56 and/or php70 repos while they install fine, do not enable for whatever reason.

    All appears to work fine and php-fpm is running, however on sites that are changed to php-fpm and the additional php version still report (via phpinfo) that php5.3 (mod_php) is in use, not the additional version via php-fpm. We've checked and the vhost for the affected sites look fine and there are no .err files.

    We've replicated this behavior on multiple systems. Essentially we are ensuring that the OS and ispconfig are fully up to date, then we install php56 from the centos6 remi repo and ensure that there is no conflicting ports on the php-fpm handler etc and we add php56 as an additional php version with these settings:

    path to php fastcgi binary: /opt/remi/php56/root/usr/bin/php-cgi
    path to php.ini: /opt/remi/php56/root/etc
    path to php-fpm init script: php56-php-fpm
    path to php.ini dir: /opt/remi/php56/root/etc
    path to php-fpm pool dir: /opt/remi/php56/root/etc/php-fpm.d

    Would be interested in any suggestions to troubleshoot/resolve this.

    thanks!
     
  4. Thaddeus

    Thaddeus New Member HowtoForge Supporter

    After changing the php version and php info still shows the previous version, have you tried manually restarting php56-php-fpm? service php56-php-fpm restart and then check phpinfo again
     
  5. ronee

    ronee Member HowtoForge Supporter

    thanks Thaddeus, yes indeed, that unfortunately does not resolve the problem, I've been digging around the various conf files to see if I can find anything amiss or any log entries that would provide a clue and all seems in order, but somehow the requests are not reaching the php56 or php70 handlers
     
  6. Thaddeus

    Thaddeus New Member HowtoForge Supporter

    You have tried it with sockets and ports?
     
  7. ronee

    ronee Member HowtoForge Supporter

    yes indeed tried both, also tried the ondemand php handler just to try it - nothing seems to change from the default php 5.3 unfortunately, thanks for the suggestions though
     
  8. Thaddeus

    Thaddeus New Member HowtoForge Supporter

    Does default php-fpm work? Try also switching to fast-cgi , if that works, then to php-fpm
     
  9. ronee

    ronee Member HowtoForge Supporter

    good idea - I thought I had already tried fastcgi but apparently not - fastcgi with the additional php versions actually does work and php56 does work in that mode, but when switching back to php-fpm & 5.6 it goes back to php 5.3 unfortunately, there is no default php-fpm handler though, that is not available with php5.3 that is included in the default centos repos I dont think
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that mod_fastcgi is installed beside of mod_fcgi in apache on CentOS 6.
     
  11. ronee

    ronee Member HowtoForge Supporter

    ok thanks Till that sorted it out much appreciated, although in order to get everything working I had to comment out FastCgiWrapper On in /etc/httpd/conf.d/fastcgi.conf, not sure if that was the best approach or not, until that line was commented out I was getting 404s on any php script where php-fpm and an additional php version was enabled. The corresponding error.log to those errors would show:

    [error] [client x.x.x.x] File does not exist: /var/www/clients/client1/web3/cgi-bin/php5-fcgi-x.x.x.x-80-host.domain.of.site
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, it might be necessary to turn it off globally as ISPConfig enables it in the vhost.
     

Share This Page