attempt to connect to Unix domain socket /var/lib/php5-fpm/web9.sock (*) failed

Discussion in 'Installation/Configuration' started by muekno, Feb 25, 2020.

  1. muekno

    muekno Member HowtoForge Supporter

    found similar problems here but do not solve
    1) I have one server debian buster with ispconfig3.1 slave build following tutorial perfect server debian buster wit a typo3 web site running fine
    2) I have a server in a similar testsystem slave build following tutorial perfect server debian stretch runing fine with a no longer existing typo3 site same typo3 version as above.
    3) Did an inplace update to buster, went fine, added a new website for test, run fin with html. Started adding typo3 version as in 1) with same php optiones, just corrected the path to php log, (did the same procedure server times,always working.
    Settings
    <coode>
    upload_max_filesize=10M
    post_max_size=10M
    memory_limit=256M
    suhosin.request.max_varname_length=200
    suhosin.post.max_name_length=200
    suhosin.get.max_name_length=200
    suhosin.get.max_value_length=2000
    max_execution_time=300
    suhosin.executor.include.whitelist=phar,vfs
    always_populate_raw_post_data=-1
    max_input_vars=1500
    display_errors = On
    error_log = /var/www/clients/client1/web9/private/php_error.log
    </code>
    got error
    <code>
    attempt to connect to Unix domain socket /var/lib/php5-fpm/web9.sock (*) failed
    [Tue Feb 25 21:47:30.492776 2020] [proxy_fcgi:error] [pid 20355] [client 172.16.1.104:53023] AH01079: failed to make connection to backend: httpd-UDS
    </code>
    made php script for phpinfo(), running from command line. works fine, running from apache error as above
    php --version
    <code>
    PHP 7.3.14-1~deb10u1 (cli) (built: Feb 16 2020 15:07:23) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.14, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.14-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies
    </code>
    do you need any more information?
    Thanks for help
    Rainer
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The PHP that fails is php-fpm, not commandline php. Go through the Debian 10 perfect server guide to ensure that you installed all new packages that are required and then edit the php and fcgi configuration in ISPConfig under system > server config so that the values are correct for Deian 10
     

Share This Page