atmailopen 403 forbidden error

Discussion in 'Installation/Configuration' started by donix, Apr 28, 2010.

  1. donix

    donix New Member

    I'm trying to install a webmail client on my ISPconfig 3 server. I want to run it under the https connection used for the control panel. I successfully installed phpmyadmin this way.

    I'm running debian 5 and I've downloaded atmailopen and unpacked it at /usr/share/atmailopen

    Adding following to /etc/apache2/sites-available/ispconfig.vhost(marked with bold):

    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen 8080
    NameVirtualHost *:8080
    
    <VirtualHost _default_:8080>
      ServerAdmin [email protected]
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
    [FONT="Arial Black"][B]SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/ispserver.crt
    SSLCertificateKeyFile /etc/apache2/ssl/ispserver.key
    
    #Addon software
    alias /phpmyadmin /usr/share/phpmyadmin
    alias /atmailopen /usr/share/atmailopen[/B][/FONT]
    
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    
    Funny thing is, that I'm able to access phpmyadmin from https://server1.example.com:8080/phpmyadmin

    When I type https://server1.example.com:8080/atmailopen my browser returns 403 Forbidden: You don't have permission to access /atmailopen on this server.

    My error.log says [Wed Apr 28 01:21:07 2010] [error] [client 212.10.xxx.xxx] client denied by server configuration: /usr/share/atmailopen

    I've tried to chown -R www-data:www-data /atmailopen but with same results.
     
  2. donix

    donix New Member

    Never mind.. I solved it. Forgot to add it to ispconfig.conf also:rolleyes:
     

Share This Page