At some point in the web dir all permissions denied

Discussion in 'Installation/Configuration' started by NDIS, Sep 28, 2009.

  1. NDIS

    NDIS New Member

    hello there,

    Ive uploaded a photoalbum wich uses PHP.

    I always get this error becouse the script has no permissions.

    Warning: chmod() [function.chmod]: Operation not permitted in /var/www/clients/client1/web2/web/album/include/functions.php on line 1022
    An error occured whilst creating thumbnail for image /lloretdemar/DSCF0003.JPG
    Unable to rename [/var/www/clients/client1/web2/tmp/dalbum_5b271384333084d6abca859b30fe1334.JPG] to [./pictures/lloretdemar/_res/res_DSCF0003.JPG].
    And i realy dont know how to fix this.
    I think the user or something does not have access.

    Can someone help me out?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If a CMS system shall be able to the website, you have to set PHP either to suphp or use php-fcgi + suexec or php-cgi+suexec.
  3. NDIS

    NDIS New Member

    Thanks for your response.

    I have tryed all the options. Always the same. And if suexec is on i get internal server error 500.

    Its a photoalbum wich is generating thumbnails. It just dont have the permission rights.

    If i am on FTP in this folder: /var/www/clients/client1/web2/web/album

    i cant make folders, so with FTP i also dont have permission to do things there.

    Is it posseble to fix this?
    Last edited: Sep 29, 2009
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please enable php-fcgi with suexec. Then take am look at the error log of the website to get the detailed reason for the 500 error. Most likely you uploaded the PHP files with wrong permissions.

    Then you added the files with wrong permissions. Make sure that the files belong to the user web2 and the group client1.
  5. NDIS

    NDIS New Member

    How can i upload the files with the right permissions? I just uploaded the script to the folder album.

    I've now used FCGI PHP with SuEXEC.
    And still get this error:
    What to do! hehe,
    Thanks that you are helping me!
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if you have added chmod to the disabled functions list in the php.ini file. You have to remove it from there when you want to use chmod in your scripts.
  7. NDIS

    NDIS New Member

    How can i do this?

    i've looked in serveral php.ini files but there is no chmod in the files. so i quess its already out.

    Wich php.ini file do i need?

Share This Page