Asterisk Server.

Discussion in 'Installation/Configuration' started by rshingala, Jul 17, 2014.

  1. rshingala

    rshingala New Member


    I am new to Howtoforge, and my question is relate to Asterisk. If I post in wrong community apologies.

    My question is, I have install two asterisk server and created trunk in-beween them to talk to each other which works fine. But Callier ID is shows '[email protected]' when call from one server to another and vice versa.

    How can I get caller number in CLI and where i need to make changes please.

    Thanks for your guidance.
  2. srijan

    srijan New Member HowtoForge Supporter

    Refer these two howtos,
    they might help you.
  3. rshingala

    rshingala New Member


    I have already done configuration using GUI, so it does all settings in extension.conf file.

    Sharing here for your information please.

    exten = s,1,GotoIf($[${LEN(${FMCIDNUM})} > 6]?1-fmsetcid,1)
    exten = s,n,GotoIf($[${LEN(${GLOBAL_OUTBOUNDCIDNAME})} > 1]?1-setgbobname,1)
    exten = s,n,Set(CALLERID(num)=${IF($[${LEN(${CID_${CALLERID(num)}})} > 2]?${CID_${CALLERID(num)}}:)})
    exten = s,n,Set(CALLERID(all)=${IF($[${LEN(${ARG5})} > 2]?${ARG5}:)})
    exten = s,n,GotoIf($[${LEN(${CALLERID(num)})} > 6]?1-dial,1)
    exten = s,n,Set(CALLERID(all)=${IF($[${LEN(${CID_${ARG3}})} > 6]?${CID_${ARG3}}:${GLOBAL_OUTBOUNDCID})})
    exten = s,n,Set(CALLERID(all)=${IF($[${LEN(${ARG5})} > 2]?${ARG5}:)})
    exten = s,n,Goto(1-dial,1)
    exten = 1-setgbobname,1,Set(CALLERID(name)=${GLOBAL_OUTBOUNDCIDNAME})
    exten = 1-setgbobname,n,Goto(s,3)
    exten = 1-fmsetcid,1,Set(CALLERID(num)=${FMCIDNUM})
    exten = 1-fmsetcid,n,Set(CALLERID(name)=${FMCIDNAME})
    exten = 1-fmsetcid,n,Goto(s,4)
    exten = 1-dial,1,Dial(${ARG1})
    exten = 1-dial,n,Gotoif(${LEN(${ARG2})} > 0 ?1-${DIALSTATUS},1:1-out,1)
    exten = 1-CHANUNAVAIL,1,Dial(${ARG2})
    exten = 1-CHANUNAVAIL,n,Hangup()
    exten = 1-CONGESTION,1,Dial(${ARG2})
    exten = 1-CONGESTION,n,Hangup()
    exten = 1-out,1,Hangup()

    kindly let me know if it is fine or need to change :)
  4. srijan

    srijan New Member HowtoForge Supporter

    You can go ahead, it should be working fine
  5. rshingala

    rshingala New Member


    My outgoing call works fine with this trunk.

    In asterisk.conf I have defined "stdexten=macro"

    In extension.conf for trunk dial following rule is applying automatically while creating trunk from GUI.

    "exten = _1XXX,1,Macro(trunkdial-failover-0.3,${MUM}/${EXTEN:0},,MUM,)" but in this callerid is displaying as "asterisk" instead of extension number.

    If I change to
    "exten = _1XXX,1,Dial(MUM/SIP/{EXTEN})" my Rule for redirecting to trunk gets disabled automatically. (In this scenario callerid works fine)

    Kindly guide me how do I?

Share This Page