ASSP getting error while trying to transfer mail

Discussion in 'HOWTO-Related Questions' started by rapidos, Sep 9, 2008.

  1. rapidos

    rapidos New Member

    hello,
    I was trying to build a new anti-spam gateway that is supposed to be in front of the two existing one.

    I followed exactly this howto: http://www.howtoforge.com/assp_clamav_postfix_debian_etch

    But I'm getting the following error when trying to send me an email by connecting directly on my new smtp gateway:

    telnet ptitux 25
    ehlo localhost
    mail from:<[email protected]>
    rcpt to:<[email protected]>: Recipient address rejected: User unknown in virtual mailbox table

    And that is the point! I do not have any virtual box and I dont want to have some beacause this is just an smtp gateway. I put in the transport table the following rule

    mycompany.com smtp:[192.168.201.118]
    192.168.201.118 is the ip of the current front smtp gateway that should become the scond one :)

    this is what I have in /var/log/mail.log:

    Code:
    Sep  9 12:26:22 ptitux postfix/smtpd[16458]: warning: 172.25.100.8: hostname box.kremlin.mycompany.com verification failed: Name or service not known
    Sep  9 12:26:22 ptitux postfix/smtpd[16458]: connect from unknown[172.25.100.8]
    Sep  9 12:26:42 ptitux postfix/smtpd[16458]: NOQUEUE: reject: RCPT from unknown[172.25.100.8]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<localhost>
    
    ptitux has ip: 172.25.100.8

    Any Idea or help would be appreciated!

    Thanks a lot!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in your main.cf?
     
  3. rapidos

    rapidos New Member

    Hi,
    the situation evolved a little bit :)

    I erased my main.cf and started a new one:

    and this is the transport file
    SO I don't use mysql anymore. And so far, I don't think I will need it on this server.

    My problem is now that I just builded a wonderfull openrelay server !! I thought that the "relay_domains" directive would catch up and refuse all the domains that doesn't match. Infact not ...

    Any idea ? Maybe I should open a new thread more in adequation with this issue ?

    Cheers,
    rapidos
     
  4. rapidos

    rapidos New Member

    It seems to work now that I changed smtpd_recipient_restrictions to check_relay_domains !!

    Just have to test it in production mode now
     

Share This Page