ASSP + ClamAv @ boot

Discussion in 'Installation/Configuration' started by AkumA, Feb 26, 2007.

  1. AkumA

    AkumA New Member

    Here i am with another question.
    I got my Ubuntu Server 6.06 and i've configured ASSP to work with ClamAv.

    I've checked the "ClamAv" option and i've searched in internet about my location of Clamav socket, and i've found it here
    The problem is:
    on boot i get
    Feb-26-07 16:17:35 ASSP version 1.2.5(2) (Perl 5.008007) initializing 
    Feb-26-07 16:17:35 File::Scan::ClamAV module installed but not available, error: Cannot connect to unix
                       socket '/var/run/clamav/clamd.ctl': connect: No such file or directory
    If i restart assp when server is ready it says that there are no problem.

    I've changed the following, trying to put ASSP in a different position on my boot:
    S20assp -> S99assp

    I have S20clamav too in my
    (I have runlevel 2 in

    But the results are the same..
    it's strange because this morning i've tried simply with S21assp and it worked!
    I've rebooted the machine once again but it returned the same error.

    I can't understand why :(
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -l /bin/sh
  3. AkumA

    AkumA New Member

    lrwxrwxrwx 1 root root 4 2007-02-14 14:17 /bin/sh -> bash
  4. AkumA

    AkumA New Member

    I tought it was a Clamav file, now i've discovered that it's a clamav-daemon file (/var/run/clamav/clamav.ctl).

    I've made a cronjob for updating clamav with freshclamav; in this way i could check it out on webmin (User gets email from cronjobs), so i've removed clamav-daemon.

    I've reinstalled it and now after a few reboots seems to work (I've changed again S20assp to S21assp in /etc/rc2.d/ )

    In assp Clamav is set as a daemon so it is coherent.. but i tought that clamav-daemon was just a daemon for checking updates! :confused:

    EDIT: i read now that it's preferred to clamavscanner because it's faster.. d'oh!!!
    Ok, i've read too much things all together and i haven't read them so well..

    Now it seems to work (4 reboots).. :)
    Last edited: Feb 28, 2007

Share This Page