Apt-get Update in Feisty Problems!

Discussion in 'Server Operation' started by matey, Aug 4, 2009.

  1. matey

    matey New Member

    I know it is an old problem which does not seem to go away!but does Anyone know how to update an old server??

    I once had the solution and I think I inserted these lines in my /etc/apt/sources.list file and then I could update and install other things (ie rsync) on this server.(I formated my hard so I lost everything on my workstation)! :(

    deb http://security.ubuntu.com/ubuntu feisty-security main restricted
    deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
    deb http://security.ubuntu.com/ubuntu feisty-security universe
    deb-src http://security.ubuntu.com/ubuntu feisty-security universe
    deb http://security.ubuntu.com/ubuntu feisty-security multiverse
    deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse

    This lines didnt work today?

    The problem is that I do NOT wish to UPGRADE because I am not aware of the consequences!
    I inherited this server and I am not that good in linux (god help our company? lol ;) no we have ppl who rarely show up, besides, I am here) But we are running a whole lot of things like the older python/zope/plone and license checking software which is being used by many ppl on the wwweb daily and cant afford to screw it up!

    Besides this is a Xen guest machine and again I dont want to run a 9.x Ubuntu on a 7.x Host machine and (possibly) mess things up...

    So if anyone knows a way which I could get an update going on a Feisty 7.04 please let me and the Internet know (cuz googled to no avail)!

    Some say it is obsoleted or no longer supported, I am sorry I dont buy that crap cuz I have already updated several systems b4 so it is just matter of finding the right links (they keep moving them around I guess)?
    And I am mo0re interested in installing missing programs such as rsync or nanp/pico than upgrading really...

    And since I am not very good in linux lol :rolleyes: the link is not really enough I need the whole lines cuz they have spaces and stuff in them which won't work in normal links!

    As for rsync and other files like nano I guess i could find out where they have them and just wget them bcs there are NO GUI on these machines!

    Last edited: Aug 4, 2009
  2. id10t

    id10t Member

    Ubuntu 7.04 will reach the end of its support period on Sunday, October 19, 2008. After that date, no further listing for it will be posted here. You are encouraged to upgrade to Ubuntu 7.10.

    from: http://ubuntuforums.org/showthread.php?t=945859

    So yeah, it isn't being supported anymore. You could dig around the mirrors list and find a mirror to use possibly that hasn't purged the old packages...
  3. matey

    matey New Member

    Thanks for the reply.
    I didnt know I could upgrade to 7.10! I thought it would upgrade you to 9.x which has a lot of annoyances (selecting drivers specially for the video), it is a lot different than 7.x and as I said I could not afford to risk it.
    But I'll look into it (7.10). Thanks again.
    PS the --fix-missing option also returns errors!?

  4. matey

    matey New Member

    BTW I put these lines in thhere and it seemed to work, at least I could install nano (cuz I hate vi, it sucks)!
    sorry but when you have to do weird things with the keyboard and things still dont work, I have no better words to describe it!

    here are the lines in case:

    deb http://old-releases.ubuntu.com/ubuntu feisty main restricted universe multiverse
    deb http://old-releases.ubuntu.com/ubuntu feisty-updates main restricted universe multiverse
    deb http://old-releases.ubuntu.com/ubuntu feisty-security main restricted universe multiverse

Share This Page