Apt-get problems

Discussion in 'Technical' started by heze54, Jan 11, 2007.

  1. heze54

    heze54 New Member

    Hi,

    I'm running kunbuntu edgy version.I've donwloaded from vmware.com vmware-server.rpm and tried to install using rpm -i xxxx.rpm.

    Installation worked fine but when I tried to run.. problems. Now, I deleted the packege using synaptic and fine....but when I try to reinstall I can not.

    And, when i run apt, this error is shown:


    [email protected]:/home/heze54# apt-get upgrade
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo información de estado... Hecho
    E: El paquete vmware-server necesita ser reinstalado, pero no se encuentra un archivo para éste.


    But i can not to reinstall it not using tar.gz not using rpm...


    what can I do?

    best regards

    heze54
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    rpm is a command for RedHat and Redhat derivatives like CentOSand Fedora, apt-get is for Debian and Debian alikes (xUbuntu). It seems to me that your mixing OS distributions, which almost always results in errors.

    For VMWare on Ubuntu I think you need to build from the sources or pick the correct .deb. I've done it already couple of times past weeks for test purposes, works nicely on the server version of Ubuntu, less optimal on the Desktop version. But anyway, use the right version.
     
  3. heze54

    heze54 New Member

    re

    Hi,

    now, I only need to restore my apt command.... remove vmware-server-player or anything...but I can not.


    what can i do?


    heze54
     
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    There's a visual shell around apt that might help you, called
    Code:
    dselect
    You can search through package names and select to install, de-install or put hem on 'hold'. Maybe this helps?
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. cronnel

    cronnel New Member

    mine dosent have any listed right now but pick the not installed resedule under status button and make sure to completely remove any packages that are left over form last install. then restart ystem <some thing may still be running in memory> and try again
     

Share This Page