apt-get problem with RHEL5

Discussion in 'Server Operation' started by chipsafts, Sep 4, 2008.

  1. chipsafts

    chipsafts New Member

    [[email protected] Stuff]# uname -a
    Linux rh5.xyz.org 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64 x86_64 x86_64 GNU/Linux
    [[email protected] Stuff]# apt-get upgrade
    rpmdb: Program version 4.3 doesn't match environment version
    error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
    error: cannot open Packages index using db3 -  (-30974)
    error: cannot open Packages database in /var/lib/rpm
    E: could not open RPM database
    [[email protected] Stuff]# locate sleepycat
    [[email protected] Stuff]# yum list db4
    Loading "rhnplugin" plugin
    Loading "installonlyn" plugin
    This system is not registered with RHN.
    RHN support will be disabled.
    Setting up repositories
    Reading repository metadata in from local files
    Installed Packages
    db4.x86_64                               4.3.29-9.fc6           installed
    db4.i386                                 4.3.29-9.fc6           installed
    What is causing the apt-get to think db3 is installed? is it thinking that?
    do i need to uninstall the db4.i386 ?
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    for met it looks more like apt is not properly installed on your machine, if I see errors like this:

    but if you are running rhel (and not any clone) why don't you use the shipped up2date?

Share This Page