apt-get install bind9

Discussion in 'Installation/Configuration' started by badben, Dec 30, 2007.

  1. badben

    badben ISPConfig Developer ISPConfig Developer

    when I try to install bind9 using the perfect setup for debian etch using the above I get the following error:


    ~# apt-get install bind9
    Reading package lists... Done
    Building dependency tree... Done
    Package bind9 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    dnsutils
    E: Package bind9 has no installation candidate


    I have tried to use the /etc/apt/source.list as in the perfect setup and the original one that came on the vds.
    I have installed everything else from the perfect setup.

    Can anybody please help?
     
  2. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    Did you do an aptget update first?
    What do you see if you execute: apt-cache search bind9 ?
    What's in your /etc/apt/source.list ?
     
  3. badben

    badben ISPConfig Developer ISPConfig Developer

    I have already run apt-get update

    my /etc/apt/source.list is

    #deb http://mirrors.lycos-vds.com/debian/ sarge main non-free contrib
    #deb-src http://mirrors.lycos-vds.com/debian/ sarge main non-free contrib

    #deb http://mirrors.lycos-vds.com/local/debian sarge vds
    #deb-src http://mirrors.lycos-vds.com/local/debian sarge vds

    #deb file:///cdrom/ sarge main

    deb http://ftp.debian.nl/debian/ stable main
    deb-src http://ftp.debian.nl/debian/ stable main
    deb http://security.debian.org/ stable/updates main
    deb http://ftp.de.debian.org/debian etch main


    and the results of apt-cache search bind9 are

    # apt-cache search bind9
    bind9 - Internet Domain Name Server
    bind9-doc - Documentation for BIND
    bind9-host - Version of 'host' bundled with BIND 9.X
    bindgraph - DNS statistics RRDtool frontend for BIND9
    gbindadmin - GTK+ configuration tool for bind9
    gforge-dns-bind9 - collaborative development tool - DNS management (using Bind9)
    host - utility for querying DNS servers
    libbind9-0 - BIND9 Shared Library used by BIND
    libconfig-auto-perl - Magical config file parser
    libnss-lwres - NSS module for using bind9's lwres as a naming service

    thanks!
     
  4. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    Last edited: Dec 31, 2007
  5. badben

    badben ISPConfig Developer ISPConfig Developer

    I have just added that one the run apt-get update but still get the same problem.

    I have just downloaded bind9_9.3.4-2etch1_i386.deb
    then I ran

    Code:
    dpkg -i bind9_9.3.4-2etch1_i386.deb
    then i got

    Selecting previously deselected package bind9.
    (Reading database ... 22986 files and directories currently installed.)
    Unpacking bind9 (from bind9_9.3.4-2etch1_i386.deb) ...
    Setting up bind9 (9.3.4-2etch1) ...
    Starting domain name service...: bindnamed: capset failed: Operation not permitted
    named: capset failed: Operation not permitted
    .
     
  6. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    The Bind documentation says this about your error:
    The capability module, part of "Linux Security Modules/LSM", has not been loaded into the kernel.

    Why did you not change the sources.list as i suggested first, followed by an apt-get update ? I think things are messed up now :(
     
  7. badben

    badben ISPConfig Developer ISPConfig Developer

    i have removed all other sources so sources.list is now just

    deb http://ftp.nl.debian.org/debian etch main

    I then ran apt-get update but still got the same problem
     
  8. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

  9. badben

    badben ISPConfig Developer ISPConfig Developer

    still same problem
     
  10. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

    I would suggest to do an:

    updatedb
    apt-get update
    apt-get install bind9

    But you've installed bind9_9.3.4-2etch1_i386.deb already..:(

    It's rather late now, so go to sleep now ;)

    Good luck
     
  11. badben

    badben ISPConfig Developer ISPConfig Developer

    thanks.

    I will try to sort out the bind install problems tomorrow.
     

Share This Page