apsstandard & ISPConfig Installer

Discussion in 'Installation/Configuration' started by suther, Mar 10, 2016.

  1. suther

    suther Member

    If you look at :
    http://dev.apsstandard.org/apps/?na...egory=&package_type=&addon=&perpage=10&order=

    you see, Prestashop 1.6.1.4. but If I go to my ISPConfig 3.0.5.4p8 to: Websites ⇒ available Packages, I only see prestashop 1.4.8.2-1.

    I've try to update via: Website ⇒ Refresh Packagelist and via System ⇒ Apps & Addons ⇒ update.
    Both seems to to nothing at all.

    Can somebody tell me how to upgrade the aps-list?
     
  2. suther

    suther Member

    If look at the "Website ⇒ Refresh Packagelist ⇒ Update" button, it points to /sites/aps_cron_apscrawler_if.php
    If I run this in my Browser I've got redirected to "GitLab" (why ever!!!).
    If I run this php-Script on cli via "php -a", I got the message:
    PHP Fatal error: Class 'ApsCrawler' not found in /usr/local/ispconfig/interface/web/sites/aps_cron_apscrawler_if.php on line 41

    A full search in /usr/local/ gives... the class apscrawler there (ispconfig/interface/lib/classes/aps_crawler.inc.php ) I also have replace it by the new one like florian said: https://www.howtoforge.com/communit...could-not-be-parsed-as-xml.68854/#post-326835.
     
  3. Jesse Norell

    Jesse Norell Active Member

    ISPConfig 3.0.5 uses an older APS api (v1?), the 3.1 dev version uses the current APS api (v2?), where checking right now I do see Prestashop 1.6.1.4-133.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3.0.5 uses APS 1.0 and ISPConfig 3.1 uses APS 1.2. There is an APS 2.0 standard but that new standard is quite complex and a pure overkill to install a cms so that even the package builders don't use it yet, the up to date packages of cms systems use APS 1.2 as of today and that's supported in ISPConfig 3.1.

    So the package updater was probably working fine before your changes, it may take 10 minutes or longer to finish, so dont interrupt it and the pacjages that you get in ISPConfig 3.0.5 are the ones for the 1.0 standard, you have to filter at apsstandard.org for 1.0 packages only and you will see that the versions shown there match the ones in your list. They are not up to date as some package builders are not building for the 1.0 standard anymore.
     
  5. suther

    suther Member

    Last edited: Mar 11, 2016
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so there is probably a config error on your server or a missing php module. You can either enable php errors in php.ini (/etc/php5/cgi/php.ini on debian and ubuntu) so that you can see the error or you add a error.log line in the ispconfig apache vhost, restart apache and then check that error.log for the exact message.
     
  7. suther

    suther Member

    :confused: Oh blame on me. If I did the wget, it downloaded the git-commit page. I thougt the link from florian was a file :oops:
    I'll fix this and will see if aps works again.
    Sorry for that trouble.
     
  8. suther

    suther Member

    Ok, now the update process finished successfully. Is there a way to particulary use the aps-installer of 3.1?
    When does 3.1 will be released?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    It is unlikely that it will work without code changes.

    We will release a first alpha version this month.
     
    Jesse Norell likes this.
  10. suther

    suther Member

    Looking forward to 3.1.
    Will it be easy to upgrade from 3.0 to 3.1? I've read something about a new Theme ... bootstrap!! Thats really cool. Can't wait to have it! :cool:
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, just run ispconfig_update.sh as root on the shell.
     

Share This Page