APS Packagelist update

Discussion in 'General' started by onastvar, Nov 8, 2013.

  1. onastvar

    onastvar Member

    FYI: I am getting following warning when I try to update packagelist for APS Installer under Sites > APS Installer > Update Packagelist

    Warning: SimpleXMLElement::__construct(): Entity: line 1: parser error : StartTag: invalid element name in /usr/local/ispconfig/interface/lib/classes/aps_crawler.inc.php on line 275 Warning: SimpleXMLElement::__construct(): < in /usr/local/ispconfig/interface/lib/classes/aps_crawler.inc.php on line 275 Warning: SimpleXMLElement::__construct(): ^ in /usr/local/ispconfig/interface/lib/classes/aps_crawler.inc.php on line 275
    APS Packagelist update finished.

    I do not run "update packagelist for APS Installer" too often, last time I ran it it was okay. Anyone else has this issue?
  2. Baridas

    Baridas New Member

    I dont know if it is the same problem, but when I press "update packagelist" no apps are shown in the "avaible packages".

    After the update the folder "/usr/local/ispconfig/interface/web/sites/aps_meta_packages" shows the packages.

    This is on an fresh installation of ISPConfig on Debian Wheezy.
  3. Quaxth

    Quaxth New Member

    Instead you could use the Softaculous installer, which is ages better than the internal ISPC Apps installer!

    Got to http//remote.softaculous.com, sign up for an account for free and you'll have more than 300 Apps available for to free installation and all are updated to the latest versions. Also they support from Softaculous is just excellent if you've any problems. In hard cases they'll also connect remotely to your system and help to get all settled.

    You'll need to ad your domains to the list in your account and maybe create the MySql Database upfront from within ISPC. A few of that Scripts still using older PHP versions, so check that you've the right PHP Version installed.

    All installation has to be done using an available FTP User on Server and you've to give that user data to the setup script. Al;l is just very easy to do stuff.

    I started to test the Aps from ISPC and found that just from the 1. page (14 Aps) more than 50% were not working on my server, various errors, so I stopped with them! Will not touch again, is just a lose of time and effort!
  4. frankytown

    frankytown New Member

    So after a few hours, I think I found the problem. However I do not have an elegant solution yet.

    Either the ZeenDoc aps package returns an invalid answer from the apscatalog or aps_crawler.inc.php does not process this case properly.

    As a result, the variable $xml ends up containing the value "<" which is in turn used to initiate an XML document using the SimpleXMLElement function call, throwing an exception.

    Alltough it is not a long term solution, I added && strcmp($apps[$j],'<') to the for loop of line 271 so this package is skipped.

    Here the code snippet from line 269:

    // Before parsing, make sure it's worth the work by checking if at least one app exists
    $apps_count = substr_count($apps[$j], '<opensearch:totalResults>0</opensearch:totalResults>');
    if($apps_count == 0 && strcmp($apps[$j],'<')) // obviously this vendor provides one or more apps
        // Rename namespaces and register them
        $xml = str_replace("xmlns=", "ns=", $apps[$j]);
        $sxe = new SimpleXMLElement($xml);
    I do not think $app_count is ever going to return anything different than 0. There is some work to do there.

    WARNING : I am not a programmer and do not pretend this solution is safe to use.

    However, I hope this helps.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The issue is quite new, so it might be that apsstandard.org changed their html or broke that html so that its invalid. Please post the issue to our bugtracker http://bugtracker.ispconfig.org/ so that we can check that and implement a workaround.
  6. siucdude911

    siucdude911 New Member

Share This Page