APS installer stuck on Installation_task

Discussion in 'Installation/Configuration' started by zapp, Sep 27, 2013.

  1. zapp

    zapp New Member

    I have to say before, I'm not a big fan of APS. I was curious if it works anyway, so I tried to Install Wordpress in an account, and surprise it doesn't work.

    The simple question is: How do I remove this package now? The database was created but the files not copied. Now I have a package with status "Installation_task" now stuck under installed packages.

    How can I get rid of that? Where in the logs should an error with the installation plop up, I couldn't find anything yet.

    System is: Debian 7.0, IspConfig 3.0.5.3

    Thanks a lot!

    Florian

    Edit: Behold, there has happened something. The Database was created! So I changed the text.
    Edit: Maybe that helps, the database is listed in Ispconfig but it never got actually created on the corresponding server
     
    Last edited: Sep 27, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    possible reasons:

    a) The mysql root passwod in /usr/local/ispconfig/server/lib/mysql_clientdb.conf on this server is wrong.
    b) The aps package could not be downloadedr from apsstandard.org on the target serve.
     
  3. zapp

    zapp New Member

    Hi till,

    thank you for the quick reply. I think I found the culprit, CURL was not installed on the target server.

    I guess I could fix this problem now, but I found another problem: I have a task stuck in the Jobqueue now, that I can't get rid of. It says:
    2013-09-27 13:52 dev.myserver.de Update aps_instances

    I run a multiserver environment with virtual machines. I set both the host and guest to DEBUG and tried running /usr/local/ispconfig/server/server.sh as root user.

    The result:
    27.09.2013-14:41 - WARNING - DB::query(SELECT * FROM sys_ini WHERE sysini_id = 1) -> mysqli_query SELECT command denied to user 'ispcsrv3'@'XXXt' for table 'sys_ini'
    27.09.2013-14:41 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    27.09.2013-14:41 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.

    I looked up the warning, and it said to ignore it for now, so I guess everything seems fine. The only problem is: The task is not removed from the Jobqueue. Is there a way to get rid of it manually?

    Best

    Florian

    Edit: O.K I did it, don't know if it is the appropriate way to do so but it worked.

    I got into the aps_instances table on the host and set asp_instance_status to 2 which is "error" after that I could remove the instance from Ispconfig the normal way, and in this process the stuck Job got cleared from the Jobqueue.

    After installing CURL on the guest, the APS Installer is now working as it should. So again thanks Till for the hint. I also found the corresponding log in the meanwhile, just if anybody is curious:

    /var/log/ispconfig/cron.log
     
    Last edited: Sep 27, 2013

Share This Page